Results 1 to 7 of 7
  1. #1
    ercBOOSTED's Avatar
    Join Date
    Apr 2007
    Location
    Pittsburgh, Pa
    Posts
    1,093
    +1
    3

    HELP!!! Problems Installing Pump Housing. Have a leak.

    Just put my pump housing and impeller back in and first time out, It didn't run right. Pulled it from the water and saw that there was water in the bottom. Didn't ride long,but rpm's only hit 6000 and top speed hit 45. At idle, the ski started sputtering and sounded like it wanted to die. Don't know what the problem is. Where could water come from? Went out a second time and was out for 2 minutes. Came back and ther was about an inch of water. The ski sounded not so good. I am at someones house borrowing their internet, so I wont have access. If you have any ideas, call my cell phone at 412-537-3841. Anybody have any ideas?

    Evan
    Last edited by ercBOOSTED; 09-01-2007 at 04:42 PM.


  2. #2
    Fairlanex
    Join Date
    Aug 2007
    Location
    Cairns, Australia Summer all year round!
    Posts
    57
    You were careful to check all your hoses are on properly and none got swapped. If you swapped a cooling water hose with a bilge hose you could end up pumping it in! You would have to try pretty hard to do it though.

  3. #3
    Silence! I Keel You! earthshaker's Avatar
    Join Date
    May 2007
    Location
    Northern CA Coast
    Posts
    1,616
    +1
    2
    Quote Originally Posted by erckawasaki View Post
    Just put my pump housing and impeller back in and first time out, It didn't run right. Pulled it from the water and saw that there was water in the bottom. Didn't ride long,but rpm's only hit 6000 and top speed hit 45. At idle, the ski started sputtering and sounded like it wanted to die. Don't know what the problem is. Where could water come from? Went out a second time and was out for 2 minutes. Came back and ther was about an inch of water. The ski sounded not so good. I am at someones house borrowing their internet, so I wont have access. If you have any ideas, call my cell phone at 412-537-3841. Anybody have any ideas?

    Evan
    Do you have the interchangeable nozzle ring mod?

  4. #4
    SeaDoocer
    Guest
    call him guy's ...he's out of touch after that post..he left his cell#..he sounds desperate...don't hesitate if you have a clue for him..

  5. #5
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,994
    +1
    455
    Whats the update on this?? hope it worked out

  6. #6
    ercBOOSTED's Avatar
    Join Date
    Apr 2007
    Location
    Pittsburgh, Pa
    Posts
    1,093
    +1
    3
    The update is its in the shop. I checked everything and it all seemed right, but who knows. Couldn't find the leak. Got bad gas. My truck was stalling out like crazy and the ski was sputtering out when it was idling. I siphoned a bunch out and it was filthy. Got no calls, so I couldn't do anymore. I took it to the idiots at my dealership. Hopefully its bad gas but not sure. I do have a case filed with the gas station and they have me on video pumping the gas into the ski and my truck. 30 gallons of bunk gas sucks bad.

  7. #7
    ercBOOSTED's Avatar
    Join Date
    Apr 2007
    Location
    Pittsburgh, Pa
    Posts
    1,093
    +1
    3
    Dealer called and said that there was water in the gas. Fuel lines weren't clogged and injectors were good. Hopefully it was bogged down cause of the water in the gas and not something else. They said that it will be done tomorrow. More updates to come. I hope that fixes it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. please help!! changing out pump housings question
    By supra_power2 in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-26-2013, 12:41 PM
  2. Steering problem after pump wedge installation
    By Mike 15Fer in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-31-2008, 07:51 AM
  3. HELP!!!! Problem after Install
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 06-09-2008, 02:25 PM
  4. Have a good used yamaha twin crankshaft And pump housing
    By mrjetskey in forum Yamaha Classifieds
    Replies: 0
    Last Post: 05-23-2008, 01:38 PM
  5. Anyone have an RXP Pump Housing 4 Sale??
    By 1 FAST VE in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-04-2006, 12:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •