Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Aug 2007
    Location
    Idaho
    Posts
    174
    +1
    29

    Bought a used 06 RXP...Question after 1st ride

    I just bought a 12 hour 2006 RXP 215hp completely stock. I bought it from my local dealer who let it go at trade in price due to the end of the season up here. Took it out and am wondering what RPM's I should be hitting.

    Background info:
    Water temp 69 degrees
    Air temp 75 degrees (maybe 5-10% humidity)
    I weigh in @ 245lbs

    I only hit a max of 7650 rpms while out riding.

    The original owner supposedly sucked up a rope and they replaced the impeller and wear ring before selling. I was skeptical on the complete fix and couldn't buy an extended warranty, so I negotiated in a 2 week 100% warranty!

    What should I look for and check to make sure everything looks good. I'm new to the PWC world and have only done very limited work on my 3 week old Ultra.

    Thank you in advance
    Last edited by BLACKSTI; 09-01-2007 at 11:21 PM. Reason: typo


  2. #2
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Quote Originally Posted by BLACKSTI View Post
    I just bought a 12 hour 2006 RXP 215hp completely stock. I bought it from my local dealer who let it go at trade in price due to the end of the season up here. Took it out and am wondering what RPM's I should be hitting.

    Background info:
    Water temp 69 degrees
    Air temp 75 degrees (maybe 5-10% humidity)
    I weigh in @ 245lbs

    I only hit a max of 7650 rpms while out riding.

    The original owner supposedly sucked up a rope and they replaced the impeller and wear ring before selling. I was skeptical on the complete fix and couldn't buy an extended warranty, so I negotiated in a 2 week 100% warranty!

    What should I look for and check to make sure everything looks good. I'm new to the PWC world and have only done very limited work on my 3 week old Ultra.

    Thank you in advance
    In those conditions, you should be seeing 8000-8100 RPM. Could be any number of things. But the first things (i.e. easiest) to check are:

    oil level - when warm and on a level surface (in the water), it should be between the bends on the dipstick.

    Supercharger slip moment - does it have stock ceramic washers? If so, go to the "how to" section and read up.

    Boost leak - make sure all hose clamps are tight and hoses securely attached.

    Make sure the intake grate (under the ski) is not hanging down past the level of the hull.

    There are many other potential issues, but these are the most common.

  3. #3

    Join Date
    Aug 2007
    Location
    Idaho
    Posts
    174
    +1
    29
    Quote Originally Posted by Franko View Post
    In those conditions, you should be seeing 8000-8100 RPM. Could be any number of things. But the first things (i.e. easiest) to check are:

    oil level - when warm and on a level surface (in the water), it should be between the bends on the dipstick.

    Supercharger slip moment - does it have stock ceramic washers? If so, go to the "how to" section and read up.

    Boost leak - make sure all hose clamps are tight and hoses securely attached.

    Make sure the intake grate (under the ski) is not hanging down past the level of the hull.

    There are many other potential issues, but these are the most common.
    Yes, stock ceramic washers, but placing an order for the metal ones over the weekend. One more reason for negotiating in the 2 week warranty, just in case they decide to grenade!

    I will check the oil. Am I checking to see if it's too high (my thoughts), obviously if low, I need to do an oil change.

    Is there a diagram anywhere for the engine compartment? They had to order me an owners manual.

    Anything else major past the 3 that I can check?
    Last edited by BLACKSTI; 09-01-2007 at 11:41 PM.

  4. #4
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Well, my thought is that if none of those issues fix it, exercise your return option. The other things it could be are far more technical and aren't worth your time IMO.

  5. #5
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    Ya should be 8000 or higher.....

  6. #6

    Join Date
    Aug 2007
    Location
    Idaho
    Posts
    174
    +1
    29
    Quote Originally Posted by Franko View Post
    Well, my thought is that if none of those issues fix it, exercise your return option. The other things it could be are far more technical and aren't worth your time IMO.

    I will check all forementioned items. Can you list a few of the more technical problems? I would like to know what to ask for to be repaired if I can't figure it out with the other simplier items.

  7. #7
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Fuel pressure issues, any number of sensors not functioning properly, electrical wiring issues or just plain old bad (lemon) ski. You could chase things until the end of time.

  8. #8
    I would TAKE IT BACK TO THE DEALER and let him figure it out. Tell him max rpm's are way down and you wont' take the ski.

  9. #9
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64

    Check throttle Cable...

    My throttle cable came loose at the handlebars and gave me that exact number on rpms...

  10. #10
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    You say that the old owner changed the impeller and wear ring?

    My bet is that he put a 15/20 or something being too big for a stock ski to turn 8100. When you go back to the dealer ask them what impeller is on your ski.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bought a used trailer...several questions.
    By xray328 in forum Towing and Trailers
    Replies: 4
    Last Post: 10-01-2011, 03:06 PM
  2. 06 RXP Problems after Towing
    By x86brandon in forum 4-Tec Performance
    Replies: 41
    Last Post: 08-28-2009, 03:12 AM
  3. 2005 engine in a 06 RXP questions...
    By canadaxp in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-23-2009, 09:58 PM
  4. what to look for in used 06 RXP
    By GYTWYPT in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 06-15-2008, 10:05 PM
  5. 06 RXP question on Speed
    By automart in forum 4-Tec Performance
    Replies: 16
    Last Post: 05-07-2007, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •