Results 1 to 4 of 4
  1. #1
    Its better to burn out than fade away christian79's Avatar
    Join Date
    Jul 2007
    Location
    Marysville Ohio
    Posts
    698

    My trim isn't set right

    When my MFD reads ZERO for the trim setting my nozzle appears to be all of the way up!! How do I fix this?

    -Thanks


  2. #2
    Bing-A-Ding-Ding-Ding, Brrrrrap! Brrrrrrrrrap!!! Polaris_Nut#1's Avatar
    Join Date
    Aug 2006
    Location
    Pittsfield, MA
    Posts
    3,350
    +1
    26
    did you try trimming it all the way up and then all the way back down?

  3. #3
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39

    trim

    I always just hold the trim button down either direction till i hear the "pop" from the back for 5 seconds
    there is a pin that will skip instead of stripping
    the mfd will catch up to the trim in a few seconds of the "popping" sound
    mattman

  4. #4
    AWA Member 32DegH2O's Avatar
    Join Date
    Aug 2006
    Location
    Minneapolis, Mn.
    Posts
    2,008
    +1
    5
    I recommend you hold the trim so that it pushes the trim down till you hear the click or "pop" as someone else called it. Hold it there clicking until the MFD shows the trim all the way down. Then you can trim it back to zero and the trim nozzle should now be straight or very close to it. The reason I recommend trimming down, is because the plastic nozzel has a lot more plastic and strength in that direction around the connection pin. While trimming up, there is just a small amount of plastic to hold back the force...in a very short time, this small amount of plastic will crack and brake and now you're paying $20 for a new trim nozzle.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help! My Trim Is Killing Me
    By xanthras in forum Polaris Open Discussion
    Replies: 20
    Last Post: 08-18-2008, 11:15 AM
  2. Trim Tabs/Plate Setting In Rough Water
    By Mik72e in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 10-27-2007, 02:55 PM
  3. my trim doesn't work
    By [email protected] in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 08-17-2007, 03:53 PM
  4. my trim doesn't work
    By [email protected] in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 08-14-2007, 10:35 PM
  5. my trim
    By andy95'slx780 in forum Polaris PWC Performance
    Replies: 2
    Last Post: 10-11-2006, 11:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •