Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    Prism's Avatar
    Join Date
    May 2007
    Location
    "New" Jersey
    Posts
    826
    +1
    99

    This sucks, take a look

    2003 1300R, cylinder #3, 44 hours on ski. The only mods performed on this engine relative to the cyl condition are: EFI unit (3,4,1,7), race filter, one layer of stock head gasket, cowl openings enlarged, J gapped plugs, Klotz Ski Craft synthetic, thats it! Questions, opinions? What is the cause? Other 2 cyls look great!





    Last edited by Prism; 09-02-2007 at 08:16 PM. Reason: pictures not working


  2. #2
    2000 GPRXP 4tec shooter98xpl's Avatar
    Join Date
    Dec 2005
    Location
    Charleston SC
    Posts
    2,717
    +1
    3
    your problem is probably from the one layer of head gasket.
    SHOOTER

  3. #3
    Nothin' runs like a Deere IowanGPR's Avatar
    Join Date
    Sep 2006
    Location
    Waterloo, IA
    Posts
    1,608
    Quote Originally Posted by Prism View Post
    2003 1300R, cylinder #3, 44 hours on ski. The only mods performed on this engine relative to the cyl condition are: EFI unit (3,4,1,7), race filter, one layer of stock head gasket, cowl openings enlarged, J gapped plugs, Klotz Ski Craft synthetic, thats it! Questions, opinions? What is the cause? Other 2 cyls look great!
    the pictures didn't work.

    But are the hoses still attatched to your oil pump??

  4. #4
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11

  5. #5
    Prism's Avatar
    Join Date
    May 2007
    Location
    "New" Jersey
    Posts
    826
    +1
    99
    Hoses were all attached and working as designed.

  6. #6
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Are the ring pins still on the piston?

  7. #7
    Prism's Avatar
    Join Date
    May 2007
    Location
    "New" Jersey
    Posts
    826
    +1
    99
    Quote Originally Posted by WATER WOODY View Post
    Are the ring pins still on the piston?
    Yes, the rings are still there, they are not stuck or anything. Can post pic if needed.

  8. #8
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Im talking about the pins,in the ring channel, that the ring ends rest against.

  9. #9
    Prism's Avatar
    Join Date
    May 2007
    Location
    "New" Jersey
    Posts
    826
    +1
    99
    Quote Originally Posted by WATER WOODY View Post
    Im talking about the pins,in the ring channel, that the ring ends rest against.
    Yes, they are still there also.

  10. #10
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Did your ski have a bog in the mid range?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Take a look at this and give me some good news...
    By rxt4me in forum Videos & Pictures
    Replies: 5
    Last Post: 07-29-2010, 07:42 PM
  2. Take a look at this and give me some good news...
    By rxt4me in forum 4-Tec Performance
    Replies: 35
    Last Post: 07-18-2010, 10:10 PM
  3. Ok,start bashing me!!!! take a look at this!
    By WATER WOODY in forum Videos & Pictures
    Replies: 24
    Last Post: 07-24-2009, 02:40 PM
  4. Replies: 2
    Last Post: 06-18-2008, 08:14 PM
  5. Take a look at this!....A bit graphic...
    By GeoRXT in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 06-30-2006, 12:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •