Results 1 to 7 of 7
  1. #1
    GH Slowest Member rfjr23's Avatar
    Join Date
    May 2007
    Location
    Mesquite, Tx.
    Posts
    120

    Thumbs up Thank you xlint!!!

    I finally got around to installing the piston I got from you.

    Here are some before pics just from the top




    Here are a couple more pics from working on it yesterday and a bit this morning.





    The pics above are of the top of the piston from the side. As you can see it was pretty nasty. The reason the piston is bronke is because the piston was seized to the pin and I couldnt get it off of the rod. The rings were one with the piston as well

    Long story short I got a piston, cylinder, and head form xlint and got it finally installed and everything went perfect. I took it out for about 45 minutes. Started out easy and slowly worked in short burst and gradually built up speed. I was more afraid of pressing my luck more then anything.

    Im just glad to have it back on the water and running great.

    Thank you xlint.


  2. #2

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    hes a good guy now if we can only get him 2 ride a goldwing

  3. #3
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Quote Originally Posted by xlint89 View Post
    A couple of good eggs for sure.
    FROM ANOTHER POST

    I AGREE
    HE SAID IT AND LIVES IT HIMSELF
    MY "USED" PART WAS NEW AS H*LL
    GOOD 2 HEAR

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Glad to help. Did you find what caused the first piston to go? Don't want a repeat of that happening again.

  5. #5
    GH Slowest Member rfjr23's Avatar
    Join Date
    May 2007
    Location
    Mesquite, Tx.
    Posts
    120
    It was a lack of oil. When I got to the ski the tank was bone dry. There are 2 ways to fix that though. !. ski never goes out witout me. or 2. Block off kit and run premix. but then Im back to #1 because I dont think my wife would know how or what to do to premix let alone to mix 40:1.

  6. #6

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    aww mate she see ya with a messure cup enough i think shell take on ,

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    I keep 2, 5gal gas cans marked with 40:1 in marker. (just in case you ever forget the ratio) But a half a quart and 5 gals. is a fudge more oil than needed. So, 10 gals of gas = 1 qt. oil. Then you ONLY fill the ski from the gas cans which you take with you. Most SL's have a 9.8 gal capacity, so 2 5's end up being a full extra tank. Easy for me, and my girl NEVER touches the gas pump.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Thank You Derrick at Jet Set Performance
    By Spike in forum 2-Stroke Performance
    Replies: 0
    Last Post: 11-28-2006, 11:26 AM
  2. Thank You Brian (bttek) B Kit Rxp 79.1
    By JOSE13RT in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-27-2006, 12:20 PM
  3. thank you for the kawi section.
    By john zigler in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 09-03-2006, 05:59 PM
  4. Thank You Steve Friebe
    By Insanediego Joe in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 07-26-2006, 11:46 AM
  5. Thanks(You know who you are)
    By elebouef in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-28-2006, 08:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •