Results 1 to 6 of 6
  1. #1

    Need help with my C180

    Looks like I have a problem with my C180
    10 hrs service completed and first time trying to go to FT and
    max rpms are 6420 to 6500
    Max speed about 32 mph (same on gps)
    does anyone have that problem before?
    What should I do?????

    THX
    Matt


  2. #2

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    Uh... remember this conversation?:

    http://www.greenhulk.net/forums/show...721#post394721

    I'll forgo the witty gambling-related anecdote that should go here, and tell you to:

    1) Climb into your engine bay with flathead screwdriver.
    2) Locate the supercharger on the aft of the engine.
    3) There's a 3" hose coming straight off the back, unclamp that hose.
    4) Remove the hose from the supercharger.
    5) With the engine off, of course, stick your finger in the SC and try to spin the fan in there.
    6) If it doesn't spin freely, go to step #8
    7) If it DOES spin freely, curse freely, because one of your ceramic washers blew.
    8 )Probably a major boost leak (although you would have heard it last time you ran the boat). Ensure the air hose from the SC to the trottle body is securely attached.
    9) If you made it to this step, just take it back to the dealer.
    10) I hope you didn't get stopped at step #7!

  3. #3

    LOL

    Atlantis...I sure hope you did not just blow your washers. That would completely suck. I am playing with fire myself. I have 4 hours on the C180 and I am planning on holding out until my 10 hr service to change them out. I know I have been warned...I proceed at my own peril.

    VX1 - priceless. Here is hoping that I avoid the dreaded #7.

  4. #4
    Would gone SC will be the cause of low RPM's?
    Thank you for all your help
    Matt

  5. #5

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    Did you follow the list? When a ceramic washer breaks off the supercharger shaft, the SC produces no boost. Without the boost of the SC, the engine will only turn 6500rpms at WOT.

    The dealer doesn't nomally go into the supercharger, or do much of anything, at the 10 hour service. A few people have had their dealer change out the spark plugs at the 10 hour, which is odd, but mostly it's an oil change. Very often, they will overfill the crankcase with oil which is bad for the engine and will rob you of RPMs, but that would account for a loss of only 100 - 400rpms.

  6. #6
    Quote Originally Posted by VX1 View Post
    Did you follow the list? When a ceramic washer breaks off the supercharger shaft, the SC produces no boost. Without the boost of the SC, the engine will only turn 6500rpms at WOT.

    The dealer doesn't nomally go into the supercharger, or do much of anything, at the 10 hour service. A few people have had their dealer change out the spark plugs at the 10 hour, which is odd, but mostly it's an oil change. Very often, they will overfill the crankcase with oil which is bad for the engine and will rob you of RPMs, but that would account for a loss of only 100 - 400rpms.
    OK
    Update time
    It was a SC
    getting my rebuild with steel washers
    Brand new pomps installed
    and the boat is getting winterized
    New upgrade parts will not be available till may or june of 08 so my dealer will install brand new racing washers in it
    At least we found it what was it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Parts needed. Help with my RXP build
    By caliburst in forum Sea Doo Classifieds
    Replies: 30
    Last Post: 11-03-2008, 06:19 PM
  2. need help with my gprxp
    By cliff0413 in forum Conversion PWC Performance Skis
    Replies: 28
    Last Post: 08-18-2008, 05:04 PM
  3. Need help with my GP1200!
    By MTAINFLA in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 03-28-2008, 02:13 PM
  4. Need help with my 1050 mph
    By 1FASTXC in forum Polaris Open Discussion
    Replies: 32
    Last Post: 06-09-2007, 02:05 PM
  5. Need Help with my STLX 1050
    By Johnquest in forum Polaris Open Discussion
    Replies: 18
    Last Post: 03-15-2007, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •