Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: VTS sucks...

  1. #1
    levonhelmet's Avatar
    Join Date
    Dec 2006
    Location
    Toronto Ont Canada
    Posts
    196

    Unhappy VTS sucks...

    my VTS is and has been for a while running on and off and blowing fuses etc usually when theres the best waves all summer.when i hook the motor up to the battery it moves fine. is there a way to just bypass the black box of doom and run it off the battery with a switch? why is it so complicated to move something up and down.my old wave raider was a manual system where you twisted the grip updown and middle detents and it worked like a charm .anyone ever retro fit one to seadoo? or is there a LOW cost alternative to seadoos ridiculously badly engineered VTS?thanks,
    rant over....


  2. #2
    you could but then issue is you have no idea were it is on its postion. also you can over travel and get it stuck in that postion. i used to run mine like that till i fixed my sensor that picked up its location and showed it on the gague. i had plenty of times were i trim to far down and it would come of its screw. have to stop and pull up on it till it grab.

  3. #3
    levonhelmet's Avatar
    Join Date
    Dec 2006
    Location
    Toronto Ont Canada
    Posts
    196
    yeah my gauge reads all wrong.thats when it blows a fuse or just stops when i pover travel it becausae the gauge is reading all wrong.mineonly reads up to half way. how hard is it to fix the magnet thingy so it read correct?
    thanks

  4. #4
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    The housing doesn't go bad until you submerge it under water...

    The housing controls the signal to the gauge, and the up and down reversing of th motor, with limits to prevent you burning up the motor.

    I'd just come off the $125 and get a new housing...and be done with it.

  5. #5
    levonhelmet's Avatar
    Join Date
    Dec 2006
    Location
    Toronto Ont Canada
    Posts
    196
    well ,the housing has never been submerged.at least not by me,and the previous owner was a girl who hardley rode it.supposedly she never sank it either,but hell if i had a dollar for every time ive backed my ski in the lake and realize i forgot the drain plugs just before i get it right in there, id have more beer right now...so who knows.so yeah $125 isnt bad for a unit that is guarnteed by them to work. but ive got some bids on fleabay right now i have to wait and see if i can get one even cheaper.

  6. #6
    theres a rubber boot around the vts control arm that extends out the back of the haul. my boot ripped so i was flooding mine all the time till i fixed it. my sensor dosent read as well and more so i took out the screw and filed it down a little then jb welded a stronger magent on top of it. it now works again like it did new.

  7. #7
    levonhelmet's Avatar
    Join Date
    Dec 2006
    Location
    Toronto Ont Canada
    Posts
    196
    do you have to remove the whole unit to get to the screw?sorry if thats a stupid question,but uh..........im stupid

  8. #8
    JayZ's Avatar
    Join Date
    Feb 2006
    Location
    mississauga, ontario
    Posts
    407
    +1
    1
    you have to remove the vts linkage, rubber boot, then remove the vts motor. then you can remove the vts rod with the magnet on it.

  9. #9
    dont forget to replace vts boot or inspect it well

  10. #10

    Join Date
    Jun 2006
    Location
    toronto
    Posts
    965
    Get a Baker.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. well this sucks
    By jungo in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 08-14-2005, 08:59 PM
  2. VTS System for the RXT
    By ActionR32 in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-04-2005, 06:16 PM
  3. 04 RXP - Leak into Hull thru VTS
    By joeg in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-01-2005, 02:21 AM
  4. BREAK IN SUCKS!
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-18-2005, 10:15 PM
  5. RXP VTS Question
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •