Results 1 to 4 of 4
  1. #1
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808

    Water in nose cone

    The last 2-3 times I took my pump off, water has dripped out from the nose cone area. It might be coming from deeper in than the cone but that's just where it comes out so I figured that's where it sits. Can this be a sign that some part(s) in my pump are on its/their way out? I seem to be down some RPMs lately (have to run a 15/20r stock and 83mm ring at 1300 ft elevation just to get 8100 rpms in 70° weather with the riva s3 charger, rear air intake, and xs cooler). Maybe RXPkid can help me on this one


  2. #2
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by JFizzleJR View Post
    The last 2-3 times I took my pump off, water has dripped out from the nose cone area. It might be coming from deeper in than the cone but that's just where it comes out so I figured that's where it sits. Can this be a sign that some part(s) in my pump are on its/their way out? I seem to be down some RPMs lately (have to run a 15/20r stock and 83mm ring at 1300 ft elevation just to get 8100 rpms in 70° weather with the riva s3 charger, rear air intake, and xs cooler). Maybe RXPkid can help me on this one
    James, I've taken mine apart 5 times. The last week it had water in it and some of the grease was milky. I replaced the o-ring seals and the milky grease. Hope this will fix it. It's not normal and it will ruin the bearings if left for a long time. I would think this should be checked at least at the end of the season.

  3. #3

    nose cone

    i have been running without a nose cone

    the last time i had my pump out i noticed water in this area as well

    reinstalled nose cone and saw no performance loss.

    actually did a little better but i had a new wear ring.

  4. #4
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by lafjax View Post
    James, I've taken mine apart 5 times. The last week it had water in it and some of the grease was milky. I replaced the o-ring seals and the milky grease. Hope this will fix it. It's not normal and it will ruin the bearings if left for a long time. I would think this should be checked at least at the end of the season.
    S..T James, I thought you were talking about the pump cone...sorry!!
    I've removed my nose cone and haven't had a problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 GTX Limited- Water in pump cone.
    By sinc71 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-14-2013, 03:15 PM
  2. water in nose cone
    By warner0308 in forum 4-Tec Performance
    Replies: 10
    Last Post: 03-09-2012, 09:02 PM
  3. Water in nose cone? And a chipped pump vain
    By Rampage in forum Yamaha PWC Performance (2-stroke)
    Replies: 33
    Last Post: 07-12-2010, 06:39 PM
  4. Water in Prop Cone
    By TheEngineer in forum 4-Tec Performance
    Replies: 12
    Last Post: 01-01-2010, 09:25 PM
  5. Water in the cone fixed
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-03-2006, 02:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •