Results 1 to 2 of 2
  1. #1

    Please help stator trouble!

    Hi everyone

    I'm new here and recently bought a 2001 virage tx. 1200cc and fuel injected. Been through 2 stators already. Never ran after I bought it - the guy then put another stator in after he already said he replaced it before he sold it to me. The thing runs for 1 day then next day stator goes dies in middle of lake. Anyone have any suggestions/thoughts about this?? Kinda odd for 2 stators to go that quickly??

    Please anything would be appreciated

  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    willy, WELCOME to the Green Hulk Forums!!!
    Check for a bad ground connection to the engine block and verify all wires are clean and tight inside the electrical box.
    Verify you're charging somewhere between 13.5-14.5 volts at 3K RPM's.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please Help! Stator position (timing) 95 Polaris 750
    By TravisM in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 07-17-2011, 09:23 AM
  2. please help polaris trouble.
    By geebee in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-21-2010, 12:00 AM
  3. Please Help...Trouble Code!
    By RustySeaRustyDoo in forum 4-Tec Performance
    Replies: 34
    Last Post: 06-04-2009, 02:36 AM
  4. Please Help, jetski trouble.
    By runwaver in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 06-08-2008, 06:42 PM
  5. Major engine troubles - please help !
    By Shawn001ca in forum Polaris Open Discussion
    Replies: 28
    Last Post: 06-20-2007, 10:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts