Results 1 to 3 of 3
  1. #1

    Join Date
    Jun 2007
    Wilmington, NC

    Water in Gauge Cluster

    My friend has an 06 rxt with the all digital cluster. The cluster stopped working last time out and now has condensation in it. 2 lines on teh speedo display flicker when you turn it on. The ski is a month out of warranty. Is there anything that can be done short of buying a new cluster which I see is $380.

  2. #2
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Oldsmar, FL
    I'd still take it in....just a month out of warranty, they should try and help you!

    edit: BTW Welcome to the forum!!

  3. #3
    bron1c's Avatar
    Join Date
    Aug 2007
    Guilderland, New York
    welcome to the forum!
    my guess is a wire and and a cracked seal on the cluster for the condensation, previously said take it in and see if they will help you
    seeing how much we all pay for our skis they should give a little bit of a break

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fixed my 07 gauge cluster (water)
    By rxp steve in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-22-2015, 06:51 PM
  2. Replies: 4
    Last Post: 07-07-2011, 11:14 PM
  3. Water pressure gauge:
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-23-2006, 04:34 PM
  4. Water pressure gauge
    By Kinchyle in forum 4-Tec Performance
    Replies: 2
    Last Post: 03-22-2006, 09:44 PM
  5. how do I remove gauge cluster?
    By Lurker in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-06-2005, 02:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts