Results 1 to 3 of 3
  1. #1

    Join Date
    Jun 2007
    Location
    Wilmington, NC
    Posts
    7

    Water in Gauge Cluster

    My friend has an 06 rxt with the all digital cluster. The cluster stopped working last time out and now has condensation in it. 2 lines on teh speedo display flicker when you turn it on. The ski is a month out of warranty. Is there anything that can be done short of buying a new cluster which I see is $380.


  2. #2
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    I'd still take it in....just a month out of warranty, they should try and help you!


    edit: BTW Welcome to the forum!!

  3. #3
    bron1c's Avatar
    Join Date
    Aug 2007
    Location
    Guilderland, New York
    Posts
    492
    welcome to the forum!
    my guess is a wire and and a cracked seal on the cluster for the condensation, previously said take it in and see if they will help you
    seeing how much we all pay for our skis they should give a little bit of a break

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Any info retained in Gauge Cluster on 2002 4tec GTX?
    By jamalama in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-27-2015, 11:13 PM
  2. 04 RXP Condesation in Gauge Cluster
    By Treemn in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-08-2012, 08:43 PM
  3. Replies: 4
    Last Post: 07-07-2011, 11:14 PM
  4. 04 gauge cluster work in 06?
    By camar0 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-15-2009, 04:31 PM
  5. FS - New in Package - Gauge Cluster and Exhaust Manifold
    By Shibby1485 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 08-20-2008, 10:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •