Page 1 of 3 123 LastLast
Results 1 to 10 of 27
  1. #1
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843

    ok MAJOR PROBLEMS ANY ADVICE??

    as some of you know i traded my ski back in last yr at the end of the season .. well i bought my ski back ... i was just going to install the riva cold air kit and my s/c impellar fins are missing .......


  2. #2
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    the ski is at the dealers .. what the fuck do i need to do i dont trust them at all .. what tests do they have to do to make sure my motor isnt blown???

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,976
    +1
    1,895
    Missing? Sounds like he sucked something up into the supercharger.

  4. #4
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    where did all the pieces from the impellar go??? into the motor???

  5. #5
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    nothing was sucked in the stock intake was on jerry

  6. #6
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    is my motor gone?????? can they fight this as a warranty issue??

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,976
    +1
    1,895
    havent you been running your ski? how was it running?

  8. #8
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    nope have not had it in the water ...

  9. #9
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,699
    +1
    21
    just ,,,,,,,,,GUN IT! The stuff that is where it ain`t suppose to be will fly out. If you don`t believe me then look at the exhaust why you buddy revs it.

  10. #10
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,976
    +1
    1,895
    Chris, if the sc blade is fucked up then something was sucked up. Stock intake or not. Chances are the guy you bought it back from had this happen and has already cleaned out any debris.

    Does your engine start and not make any noise? If so you are fine. Just need a new SC impeller.

    I have a couple of stock impellers on my shelf at a very cheap price if you need one.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trailer Problem - Any Ideas?
    By Jarrett in forum Sea Doo Open Discussion
    Replies: 27
    Last Post: 05-22-2013, 03:31 PM
  2. 05 RXT major problems any ideas
    By wardie.84 in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-11-2010, 04:02 PM
  3. Bad bounce problem. Any suggestions?
    By Nickeljet in forum Yamaha Old School Skis
    Replies: 9
    Last Post: 04-04-2007, 11:10 AM
  4. gp1200 impeller any advice
    By spyder3000gtvr4 in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 09-18-2006, 10:22 PM
  5. Major Problem with my ski!
    By PMart317 in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 07-08-2006, 11:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •