Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    3

    Here's an Odd Collection Of Coolant, hmm

    pulled stock intercooler out, removed all my water lines, pulled the pump off which was stuck in place and took me awhile to get off, never had that happen before. wear ring and prop and mangled together, nose cone came off, and i found this coolant leak after i finally was able to get the pump off.

    what do you make of it?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	dsc00219_982.jpg 
Views:	96 
Size:	140.8 KB 
ID:	2830  


  2. #2

    Join Date
    Jul 2005
    Location
    Ohio
    Posts
    441
    +1
    1
    cracked rideplate someplace or either the conection tube(s)

    T

  3. #3
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,809
    Sheeze,

    Another coolant issue with the 3 seaters??

  4. #4
    Moderator two2curupt's Avatar
    Join Date
    May 2005
    Location
    Toronto, Canada
    Posts
    2,991
    +1
    41
    Steve looks like a rideplate issue...No big deal if you have warrenty....Ya one of these days I will spell that word properly...Wait till phonics lession 6 though..

  5. #5
    Moderator two2curupt's Avatar
    Join Date
    May 2005
    Location
    Toronto, Canada
    Posts
    2,991
    +1
    41
    did you suck something up???

  6. #6
    daverxp4's Avatar
    Join Date
    Aug 2005
    Location
    montreal,canada
    Posts
    1,323
    Another nose cone comming off this seems like a common thing was it a solas green nose cone or stock.

    sorry to hear about your coolant leak don't you still have it under guarantee?

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    3
    yea I have a warranty....

    no i did not suck anything up... nose cone coming off is my fault, lol... i was rushing switching props and didn't silicone or loctite the nose cone on there

    think I should just start pulling the rideplate off the ski? it's gonna be a biotch!

  8. #8
    Senior Member watermedic's Avatar
    Join Date
    Apr 2005
    Location
    West Virginia
    Posts
    383
    Shib, Do you have any way to pressurize the cooling system and try to detect the leak that way--before you pull the ride plate?

  9. #9
    Was your coolant much lower? If it's not leaking much could you put that radiator leak fix stuff in it ? Then it would ahere to the cracks in the hoses ?
    maybe that's a stupid question

  10. #10
    Quote Originally Posted by Kinchyle
    Was your coolant much lower? If it's not leaking much could you put that radiator leak fix stuff in it ? Then it would ahere to the cracks in the hoses ?
    maybe that's a stupid question
    What??? no powder or pills or beans in these cooling systems, sheesh ...PR...

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Here's an easy one.....................lol..!!!
    By la90043 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 10-21-2007, 08:19 PM
  2. Here's an easy one, part 2
    By turk0004 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 10-21-2007, 05:10 AM
  3. Here`s an Idea!
    By Pale Rider in forum Open Discussion
    Replies: 9
    Last Post: 11-17-2006, 11:14 PM
  4. Here's An Idea For All The Tuners.
    By ABBOTT in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 09-22-2006, 02:40 AM
  5. 40/60 mix of coolant?
    By Griff350 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-17-2005, 10:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •