Results 1 to 7 of 7
  1. #1
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241

    Pump This Up! Hhahahahah!

    i took my pump off to install my stainless wear ring and i notice my pump shoe has a groove about 3/8" into my shoe and about 1/8" deep all the way around????? so i take the prop out of the pump and stick it on the shaft and its a good 1"+ away from where the groved edge in the pump shoe starts and goes forward towards the front of the boat 3/8" into the shoe 1/8" deep all the way around. it looks as though it was the prop cutting into the pump shoe but i cannot for the life of me figure out how it could travel 1"+ towards the front of the boat inside the pump itself and another 3/8" deeper out of the pump carving into the pump shoe because the prop DOESNT MOVE forwards or back after being tightened into the pump itself to my knowledge and sets 1"+ deep inside the pump to begin with so im LOST!!!!! how could the prop travel 1 3/8"+ back and forth in the pump and eat that groove into the back of that shoe? just tell a REDNECK HILLBILLY PLEASE!!!!!!!!!!!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSCN2047.JPG 
Views:	91 
Size:	176.5 KB 
ID:	37856   Click image for larger version. 

Name:	DSCN2055.JPG 
Views:	70 
Size:	164.3 KB 
ID:	37857   Click image for larger version. 

Name:	DSCN2059.JPG 
Views:	70 
Size:	169.0 KB 
ID:	37858   Click image for larger version. 

Name:	DSCN2051.JPG 
Views:	71 
Size:	158.2 KB 
ID:	37859  


  2. #2
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,282
    +1
    2
    The same thing happened to mine. All I can tell you is at some point you sucked something through the pump and gouged it as the prop turned it, before sucking it out through the nozzle!

  3. #3
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    i was thinking a stick could have been in there or something of that nature but it was weird when i looked and it was so even and cut around the inside of the pump shoe it tripped me out like the blade had MOVED even though i know it CANT!!

  4. #4

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14

  5. #5

    Join Date
    Jun 2005
    Location
    rome ga
    Posts
    938
    +1
    20
    Your impeller probably came loose and moved forward. When it comes loose it can push the whole motor forward.

  6. #6
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    it was still tight in the pump when i removed it and seen this cause i thought that but it wasnt loose is the thing thats baffling me!!!!!!!!!!

  7. #7
    75 mph on a budget TorquePhoto's Avatar
    Join Date
    Jul 2006
    Location
    Lake St. Clair, MI
    Posts
    360
    torn motor mounts????

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Could we real this up?
    By ShaneG in forum Polaris Open Discussion
    Replies: 14
    Last Post: 01-29-2008, 10:45 PM
  2. Picking this up on Sunday!
    By seadoo951 in forum Other Toys
    Replies: 4
    Last Post: 10-28-2007, 12:52 PM
  3. jet pump locked up
    By Mark93spx in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-07-2007, 02:14 PM
  4. What is Ideal pump set-up?
    By xlint89 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 10-14-2006, 06:52 PM
  5. Can someone in Texas pick this up for me?
    By J-ME in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 02-11-2006, 07:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •