Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1


  2. #2
    race jase's Avatar
    Join Date
    Feb 2007
    Location
    auckland nz
    Posts
    539
    +1
    46
    overproped!
    what prop are you running?

  3. #3
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    879
    +1
    11
    its a stock prop that les welded around the perimeter and then machined back so as to give zero clearance up against the wear ring which gives zero cavitation off the line and then he repitched it to what I dont really know but i he said I could use it in the stock class back in 99.

  4. #4
    race jase's Avatar
    Join Date
    Feb 2007
    Location
    auckland nz
    Posts
    539
    +1
    46
    stock props normally need to be reworked to run with the coffmans pipe as they are a little tall.

  5. #5
    PiMPNXP's Avatar
    Join Date
    Dec 2005
    Location
    So Cal.....
    Posts
    612
    what venturi nozzle are you running?

  6. #6
    race jase's Avatar
    Join Date
    Feb 2007
    Location
    auckland nz
    Posts
    539
    +1
    46
    Dan the man
    How you been?
    jase

  7. #7
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    879
    +1
    11
    Quote Originally Posted by PiMPNXP View Post
    what venturi nozzle are you running?
    Im running the stock nozzle . ??????????

    I have a nozzle that has been bored to 87mm so I thought I might try that ????????

  8. #8

    Join Date
    Apr 2005
    Location
    Eureka, MO
    Posts
    404
    +1
    1
    The stock 98 XP-L nozzle opening is 85.5mm. Try the 87mm nozzle. Sounds like your impeller is a bit too tall so if the 87mm nozle dosen't do it, try a smaller impeller.

    Have you pressure tested the coffman pipe to be sure that it isn't leaking internally?

    Dan (drb)

  9. #9
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    879
    +1
    11
    Quote Originally Posted by drb View Post
    The stock 98 XP-L nozzle opening is 85.5mm. Try the 87mm nozzle. Sounds like your impeller is a bit too tall so if the 87mm nozle dosen't do it, try a smaller impeller.

    Have you pressure tested the coffman pipe to be sure that it isn't leaking internally?

    Dan (drb)
    To do this accurately what pressure should it take and for how long ????

  10. #10

    Join Date
    Apr 2005
    Location
    Eureka, MO
    Posts
    404
    +1
    1
    I pressure test the pipe at 15 psig for 10 to 15 minutes. Usually if there is an internal crack you will hear it leaking right away.


    Dan (drb)

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 SLT 780 help. Motor wont rev past 4000
    By nz253 in forum Polaris Open Discussion
    Replies: 32
    Last Post: 10-11-2015, 05:45 PM
  2. 1996 sl780 wont rev past 4000
    By snoopy'sbitch in forum Polaris Open Discussion
    Replies: 31
    Last Post: 06-30-2010, 05:36 PM
  3. FS Fresh Rebuilt 750 Also Dry Pipe Set-up
    By beerdart in forum Polaris Classifieds
    Replies: 7
    Last Post: 01-23-2010, 02:41 PM
  4. ultra 150 wont rev past 4000 rpm
    By jramos in forum Kawasaki How To & FAQs
    Replies: 8
    Last Post: 07-15-2008, 06:47 PM
  5. triple pipe set up question?????
    By TheDome in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 01-14-2007, 10:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •