Results 1 to 7 of 7

Thread: 2000 Virage 700

  1. #1

    Join Date
    Mar 2007
    Location
    West Fargo, ND
    Posts
    144

    2000 Virage 700

    This ski has 85 hours on it and I have a pump problem.

    the ski runs and idles good, but when you add power to her she starts to accelerate and begins to plane out when all of a sudden she stalls out and motor sort of revs up. If you accellerate in a tight corner she planes out and runs well. It is in the impeller I think? I took the pump off and brought the impeller assembly to my local Polaris dealer (a good dealer that will try and help with any ski problem) and they told me they expected it to look worse than it did. They said to put a new impeller on and it should fix the problem. The rear fins a slighly bent and the leading edges are not bad, I will fill the leading edges first and then take her for a test run. If that doesn't fix her I may have to buy a new impeller. Should I go stock or what, I heard some of the after market impellers do not fit the best and they some times make contack with the wear ring.

    Any help thanks.


  2. #2
    FLjoyrider's Avatar
    Join Date
    Jul 2007
    Location
    Florida
    Posts
    555
    Check the wear ring to impeller clearance. If it is excessive I would try replacing the wear ring first then maybe moving to the impeller. One other thing to check out might be the drive shaft, make sure all the splines are in good shape.

  3. #3

    Join Date
    Mar 2007
    Location
    West Fargo, ND
    Posts
    144
    I brought the drive shaft in and they said there is no wear on either end and that I need to just remember to put some grease on each end when re-installing it.

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    I would send the stock impeller to Impros and let them work some magic on it.

  5. #5

    Join Date
    Mar 2007
    Location
    West Fargo, ND
    Posts
    144
    Do you have a phone #?

  6. #6
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Ask for Dave
    http://www.impros.com/

  7. #7

    Join Date
    Mar 2007
    Location
    West Fargo, ND
    Posts
    144
    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. W.T.B CDI Box for 2000 Virage 700
    By cclubber3 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-09-2010, 10:13 PM
  2. 2000 virage 700 twin carbs
    By blu in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-07-2010, 09:35 AM
  3. 2000 virage 700 cc
    By goran_volvo in forum Polaris Open Discussion
    Replies: 3
    Last Post: 03-22-2010, 07:20 PM
  4. 2000 Virage 700 start/sop problem
    By prostang306 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-09-2009, 01:30 PM
  5. 2000 Virage 700
    By repoman in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-14-2007, 08:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •