Results 1 to 5 of 5
  1. #1
    friebe1's Avatar
    Join Date
    Mar 2006
    Location
    Clovis, Ca
    Posts
    224

    mod ecu on o5 rxp- check engine, knock sensor

    With the rotax mod ecu I get a check engine light with a knock sener code. The boat runs at 8400 very strong. The ecu says right on it for use without knock control? Is it safe to ride in this condition, and what can be done to elimanate the check engine.
    Sorry if it is posted elseware but I am at a race with limited computer use.

    Thanks for any help.
    Steve Friebe
    559-313-1167


  2. #2
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    next time u get the check engine light... press set 5 times quickly, it will give u a code...

    it's gonna be a knock sensor fault...

    on the 05 ski with a Rotax Racing ECU, you need to disect the stock wiring harness and cut the knock sensor resistors out of the harness, then solder wire extensions and put the plug back on... that will solve your problem...

    u'll find the knock sensor integrated in the 05 harness as a 6" long bulge about 3/8" thick.... it's a round long black bulge... inside that is a few circuits and resistors and whatnot... snip the wire right against the bulge on both ends. u'll find a blue/yellow wire.. and further peel back the wire wrapping and u'll find an UN-insulated wire that also needs to be extended to mate the plug back on it


    now u ultimatey have an ski wired like an 04 RXP... if u want to put the knock sensor back in, jsut get a piggy back harness jumper and plug it in and u have ur knock sensor back for the stock ECU

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,995
    +1
    1,900
    Steve, welcome to the forum!

    Looking forward to seeing you guys in Havasu again this year.

    What shibby said is correct. You must remove the resistor out of the wire harness going to the knock sensor.

  4. #4
    friebe1's Avatar
    Join Date
    Mar 2006
    Location
    Clovis, Ca
    Posts
    224
    Thanks for the help. We did the resistor removal at the race site on saturday morning. Worked just fine.

    Yes we will be in Havasu again. This year it will be the Supercourse world finals!!

  5. #5
    Quote Originally Posted by Shibby1485 View Post
    next time u get the check engine light... press set 5 times quickly, it will give u a code...

    it's gonna be a knock sensor fault...

    on the 05 ski with a Rotax Racing ECU, you need to disect the stock wiring harness and cut the knock sensor resistors out of the harness, then solder wire extensions and put the plug back on... that will solve your problem...

    u'll find the knock sensor integrated in the 05 harness as a 6" long bulge about 3/8" thick.... it's a round long black bulge... inside that is a few circuits and resistors and whatnot... snip the wire right against the bulge on both ends. u'll find a blue/yellow wire.. and further peel back the wire wrapping and u'll find an UN-insulated wire that also needs to be extended to mate the plug back on it


    now u ultimatey have an ski wired like an 04 RXP... if u want to put the knock sensor back in, jsut get a piggy back harness jumper and plug it in and u have ur knock sensor back for the stock ECU
    Hello guys, what I would like to know if after this our SENSOR work? or clear only the light turns on at 5000 rpm. Hello, thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 05-07-2010, 02:18 PM
  2. engine knock sensor
    By WHEELINMAN in forum Honda Open Discussion
    Replies: 5
    Last Post: 08-09-2009, 01:43 AM
  3. How To: Install RR ECU after the knock sensor update 04 RXP
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 15
    Last Post: 06-14-2008, 12:13 PM
  4. Removing knock sensor on 2005 rxp for rr ecu
    By Chezzy in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-13-2006, 07:34 PM
  5. Getting "Check Engine" message on 04 RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-20-2005, 01:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •