Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: summerize info

  1. #1

    Join Date
    Jul 2005
    Location
    Indianapolis, IN
    Posts
    176

    summerize info

    i have a 05 rxp that was winterized at the dealer, and for the price they charge to prepare it for summer, i was thinking that i could do it myself. i believe they changed the oil ( it's a tan color right now ). I think they did all the stuff right to prepare it for winter. what do i need to do to prepare it for summer? thanks


  2. #2
    Did you charge up the battery? remember to remove from ski, and 2 amp max charger.
    Is your fuel tank full, if not top off with fresh fuel.
    visually check everything, wire connectors, hose clamps, coolant level in bottle, fuel tank straps, see if anything is dislodged or loose, spray some Bomb lube thru exit nozzle onto wear ring and prop edges, after satisfying yourself with looking it over, have hose attached, pop on the lanyard, fire it up, turn on hose, if machine was fogged with storage oil it will smoke for a few minutes, only let ski run on hose for a few minutes, shut off hose, rap throttle to clear some water in exhaust, and shut off...PR...

    anybody, did I miss anything?...

  3. #3

    Join Date
    Jul 2005
    Location
    Indianapolis, IN
    Posts
    176
    Quote Originally Posted by Pale Rider
    Did you charge up the battery? remember to remove from ski, and 2 amp max charger.
    Is your fuel tank full, if not top off with fresh fuel.
    visually check everything, wire connectors, hose clamps, coolant level in bottle, fuel tank straps, see if anything is dislodged or loose, spray some Bomb lube thru exit nozzle onto wear ring and prop edges, after satisfying yourself with looking it over, have hose attached, pop on the lanyard, fire it up, turn on hose, if machine was fogged with storage oil it will smoke for a few minutes, only let ski run on hose for a few minutes, shut off hose, rap throttle to clear some water in exhaust, and shut off...PR...

    anybody, did I miss anything?...
    Thanks, im charging the battery now. I thought it would be somthing different because of the cooling system

  4. #4
    I got mine out and started it today. I didn't do any winterize to speak of, except putting Sta-Bil in the gas before the last trip. I unhooked the battery after it sat up for about 3 months.

    I pulled it out today after putting the pump back on, hooked up the hose, hooked up the battery (not necessarily in that order) and fired it up. I was surprised it started right up, no starter drag or nothing.

    Took it out to the lake, once it got warm enough, I realized I needed to put the new plugs sitting on my tool box in. I ran it hard for a little while and it cleared out though.

  5. #5

    Join Date
    Oct 2005
    Location
    Ann Arbor, MI
    Posts
    1,439
    You may want to hold the throttle all the way down and hold the start button for about 10 secs so you dont get a dry start! Just a FYI!

  6. #6
    Would that cause the computer to go into a flood condition, where it shuts off the injectors to clear a flood? I know other fuel injected cars do that, not sure abotu the 4tec though.

  7. #7

    Join Date
    Oct 2005
    Location
    Ann Arbor, MI
    Posts
    1,439
    yeah it puts it in flood mode and doesnt allow the engien to start but it will crank over and get oil over everything, so you dont get a dry start...

    Then stop holding the start button release the throttle wait about 5 secs and hit the start button and she should fire right up!

  8. #8
    Maybe he meant golden colored.

  9. #9
    Quote Originally Posted by Totallyblown
    yeah it puts it in flood mode and doesnt allow the engien to start but it will crank over and get oil over everything, so you dont get a dry start...

    Then stop holding the start button release the throttle wait about 5 secs and hit the start button and she should fire right up!
    I was on a different page .... sorry. I thought you meant a dry startup as in fuel.

    Now that we're on the same page, not a bad idea.

  10. #10
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    tiplick...... your oil is TAN? tan as in what would u compare it to... never heard someone describe oil color as tan... that worries me

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 10hr service info & questions
    By checkerboard in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-18-2008, 07:20 AM
  2. TIP - Bar Extensions and Wear Ring Info
    By MikeTrin in forum Sea Doo How To & FAQs
    Replies: 7
    Last Post: 06-19-2007, 03:05 PM
  3. hey hulk, info on the paint used for ski (green to black)
    By mxl16 in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-14-2006, 07:11 PM
  4. Truth, myth and fact about engine break in.. Good info ..
    By 05rxt in forum 4-Tec Performance
    Replies: 17
    Last Post: 07-04-2005, 04:14 PM
  5. Hey guys a couple of small tips about our boats...good info
    By two2curupt in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-21-2005, 04:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •