Results 1 to 5 of 5
  1. #1

    Join Date
    Sep 2007
    Location
    Philadelphia, Pennsylvania, United States
    Posts
    251

    95 SLT 750 Multifuncton display

    hello, I am new to the forums here and was wondering if I could get a little assistance. i purchased a SLT 750 today for what I think is a great price (800 WITh trailer) and I think Its having a little problem. The Display keeps reading LOW PR or something like that. The only thing I have done to it so far is a new battery. It starts rght up while on the hose but sounds like its breaking up at full throttle. (only did this for a second). When IN the water under load it seems like it takes a second for the inpeller to "catch" and then it zooms right off. Any assistance would be great. Also Im trying to find a manual or something for the multifuntion display and the codes it uses. thanks!


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by Oneboss302 View Post
    hello, I am new to the forums here and was wondering if I could get a little assistance. i purchased a SLT 750 today for what I think is a great price (800 WITh trailer) and I think Its having a little problem. The Display keeps reading LOW PR or something like that. The only thing I have done to it so far is a new battery. It starts rght up while on the hose but sounds like its breaking up at full throttle. (only did this for a second). When IN the water under load it seems like it takes a second for the inpeller to "catch" and then it zooms right off. Any assistance would be great. Also Im trying to find a manual or something for the multifuntion display and the codes it uses. thanks!
    Others will chime in with the diagnostics approach to use, but here is the MFD operating info;
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Polaris MFD type1-2.jpg 
Views:	100 
Size:	109.7 KB 
ID:	38629   Click image for larger version. 

Name:	Polaris MFD type1-21.jpg 
Views:	86 
Size:	150.7 KB 
ID:	38630   Click image for larger version. 

Name:	Polaris MFD type1-22.jpg 
Views:	78 
Size:	137.7 KB 
ID:	38631  

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    If you have the round style MFD, I think it works about the same as the bigger one.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Polaris MFD directions A.jpg 
Views:	67 
Size:	165.2 KB 
ID:	38632   Click image for larger version. 

Name:	Polaris MFD directions B.jpg 
Views:	73 
Size:	189.4 KB 
ID:	38633  

  4. #4

    Join Date
    Sep 2007
    Location
    Philadelphia, Pennsylvania, United States
    Posts
    251
    Thanks for the helpful info! Now... for the hesitation problem. Any suggestions where to start?

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Welcome to the Hulk. Does it feel like the impeller is "spinning tires?" If so, you may have some cavitation or an impeller problem. You'll need to inspect the impeller and pump for problems like broken vanes, bent edges, etc... Also slip a feeler gauge between the impeller and the wear ring it slides into on the pump. The gap shouldn't be more than .020. You should get a service manual if you're going to be doing work yourself.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. fuel primer for 95' slt 750
    By xplayer2885 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 08-03-2008, 09:13 AM
  2. 95 SLT 750 drive coupler
    By SharkCrazy in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-26-2007, 11:12 PM
  3. 95 slt 750 hard start
    By tlbailes in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 06-08-2007, 12:18 AM
  4. TDR water box for 95 slt 750
    By xplayer2885 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 01-01-2007, 12:25 PM
  5. 95 slt 750 wont charge
    By The Joker in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 12-13-2006, 03:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •