Results 1 to 4 of 4
  1. #1

    Join Date
    Sep 2007
    Location
    Philadelphia, Pennsylvania, United States
    Posts
    251

    MFD only reading .5 volts?

    The MFD is only reading .5 volts. Brand new batt installed yesterday. any suggestions?


  2. #2
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Didn't you have a LO PWR message? This may be a voltage regulator problem.

  3. #3

    Join Date
    Sep 2007
    Location
    Philadelphia, Pennsylvania, United States
    Posts
    251
    Quote Originally Posted by Tony View Post
    Didn't you have a LO PWR message? This may be a voltage regulator problem.
    Yes, thats what Im thinking. Currently searching the forums for how to troubleshoot this. any suggestions?

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    To re-set the MFD
    Press and hold the MODE and SET keys until the CAL displays. The CAL display will usually show after 4 seconds
    Press and hold the SET key
    While continuing to hold the SET key ans within 2 seconds of pressing the SET key, press and hold the MODE key
    Don't release either key until the MFD shuts down
    After the MFD has shut itself down, press the mode key to turn the MFD on
    Depress the MODE key repeatedly until voltage is displayed and verify that the voltage reading has been restored.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Polaris SLH700 MFD error reading with video
    By ghostridermb in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-22-2011, 11:00 PM
  2. Innovate air /fuel only reads 20
    By IBADTON in forum 4-Tec Performance
    Replies: 14
    Last Post: 06-06-2011, 09:48 PM
  3. Newby here with MFD issues... read forum front to back
    By covy in forum Polaris Open Discussion
    Replies: 14
    Last Post: 07-07-2009, 09:10 PM
  4. MFD not reading gas level
    By invetteve in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-03-2009, 08:15 AM
  5. Speedo only reads 54-56mph...
    By Mitchlguzin in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 08-06-2007, 08:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •