Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843

    s/c imp question....

    ok so my bearings are fine ceramic washer in place and clutch passed the test YET my s/c imp is destroyed as is my housing ... my dealership is not going to process as warranty work because they are saying it is clear something was ingested and it was not a manufacture defect so i have to eat the repairs and hope my motor is fine I am scared to death rite now to be honest They claim they also contacted seadoo and it will not be covered because the only way that could have happened was something was ingested weather it be a washer a bolt or some type of debris ... my question is .. Is there something they are missing that could have went bad ??? or was something ingested and i just have no fucking clue what is there anyway something went bad or broke and they are missing it or are they the only 3 things that could have went bad ???????


  2. #2
    Did you ever find any of the pieces lodged anywheres?...PR...

  3. #3

    Join Date
    Oct 2005
    Location
    Ann Arbor, MI
    Posts
    1,439
    Didnt you sink your ski while it was running?? Or am I thinking of someone else?

    If so that 20 gallons of water the filled your hull, went in your itnake and the pressure sheard the blades clean off...

  4. #4
    crazed, yeah your'e crazy alright..........just like me Chris sounds like you did in-jest something, when did this happen? during a break-in period? sitting on the trailer running? Some-one I know sucked up a tow rope you could take off your plug wires and see if the engine will turn over, and if does, hear for any wierd sounds, and by no means do not try to start with SC off, I did it once and the sound was un-bearable Other than that got a brand spanking new black 05 SC with les washers (stock).

  5. #5
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    u pull that stock intercooler out yet to see if the SC blades are caught up in the mesh of the intercooler?

    do a compression test on the machine?

    i'd further inspect things before u jsut slap a new SC housing and impeller in there... and who cares if it passes the slip test, u need to take the shaft and clutch apart to replace the housing anyways.

  6. #6
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    i get what everyone is saying but what im asking is could something else have happened to fuck the impellar up that they are screwing me with ??? or did i just ingest something and not know it ... by the way yes i ingested water however that was wayyyy back and ski ran fine after that

  7. #7
    Quote Originally Posted by CRAZEDRXP
    i get what everyone is saying but what im asking is could something else have happened to f$%k the impellar up that they are screwing me with ??? or did i just ingest something and not know it ... by the way yes i ingested water however that was wayyyy back and ski ran fine after that
    you didn`t notice any performance loss? this is the ski that you re-purchased, and this time you find the SC trashed!?yes?...PR...

  8. #8
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    YESSSSSSSSSSS

  9. #9
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    unfortunatley i have no way in getting in touch with who had the ski last so i cant ask him if he ingested something or not i just wanan know Iffff something could have went wrong or are they rite and something was ingested ....

  10. #10
    CRAZEDRXP's Avatar
    Join Date
    Apr 2005
    Location
    PHILADELPHIA
    Posts
    843
    They are saying for the imp to implode like it did and get all fucked up it would have had to either have a bad ceramic washer a bad clutch or bad bearings .. all of which are fine .... are they rite or are they overlooking something

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  2. 158 Thermostat question...
    By rx4pain in forum 4-Tec Performance
    Replies: 34
    Last Post: 11-21-2008, 10:36 PM
  3. rr sc imp question
    By CRAZEDRXP in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-01-2006, 02:10 AM
  4. S/C IMP & BOV INSTALLED
    By CRAZEDRXP in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-07-2005, 07:28 PM
  5. SuperCharger Imp Install hours away
    By CRAZEDRXP in forum 4-Tec Performance
    Replies: 18
    Last Post: 05-06-2005, 06:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •