Results 1 to 10 of 10
  1. #1

    Join Date
    Sep 2007
    Location
    New Jersey
    Posts
    8

    Need Help GPR Too Slow

    Hi I'am new to the forum and I love it. I have a 2003 Gp1300r with a Riva stage 1 kit with a race filter. The ski will not go over 66-67 mph, one time it hit 68mph but it took forever. Is this normal or should I expect more out of it, what else do I need to do. Thanks


  2. #2
    Chrisrokc's Avatar
    Join Date
    Apr 2006
    Location
    Oklahoma City, OK
    Posts
    3,667
    Quote Originally Posted by GPR4EVER View Post
    Hi I'am new to the forum and I love it. I have a 2003 Gp1300r with a Riva stage 1 kit with a race filter. The ski will not go over 66-67 mph, one time it hit 68mph but it took forever. Is this normal or should I expect more out of it, what else do I need to do. Thanks
    Sounds about right to me. How are you getting the speed numbers? Stock speedo or GPS? The stock speedos are alllll wrong. Mine was reading 88-92 mph when i was running 73mph.


    If those are speedo numbers I would get a GPS. I would also get my rideplate modded. That will slap on a few more mph!

  3. #3

    Join Date
    Sep 2007
    Location
    New Jersey
    Posts
    8
    The mphs are from a GPS. Can I do the rideplate mod myself, what must be done to it, if not who do you suggest.

  4. #4
    james k's Avatar
    Join Date
    Aug 2007
    Location
    Panama City Beach,FL
    Posts
    950
    +1
    1

    Rideplate Mod :::

    ( Jims Performance ) on the forum home page....

  5. #5
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    welcome to the forum GPR4EVER

  6. #6
    Prism's Avatar
    Join Date
    May 2007
    Location
    "New" Jersey
    Posts
    826
    +1
    99
    Hello and welcome to the forum! I have the same boat as you do. When it was stock it would run 64.2 mph on the buzzer and on the seat. Are you using all the stage 1 parts? EFI controller? There is alot of info on this forum that will absolutly guide you in the right direction. Using the search feature unleashes tons of info on just about any part on your GPR. Just type in the part you have a question about, such as "sponsons" and you will be rewarded with bountiful info. There is alot of free speed you need to know about. 68 seems pretty good for what you have, but after you do some research, you will easily go into the low 70's without spending a dime. Good luck! If you need any help just ask!

    Alan

  7. #7
    PuprleNuprleGPR's Avatar
    Join Date
    Jul 2006
    Location
    Central FL
    Posts
    741
    That sounds about right.
    My 04 GP1300R did only like 61.8 with only mod being R&D intake grate.

  8. #8
    injected2stroke's Avatar
    Join Date
    Feb 2006
    Location
    Taylor Mi.
    Posts
    255
    I have a 2003 and those numbers aren't bad but you can get more out of her.
    Just make sure that you set the pump shoe and ride plate up correctly with the new yamaha inserts and the ride plate inserts and make sure that before you get to involved with anything else that you reinforce the pump tunnel this is a must if you have plans on increasing the speed of your 2003.

  9. #9
    philip_gpr's Avatar
    Join Date
    Dec 2005
    Location
    Canada
    Posts
    2,724
    +1
    3
    lot's of info here

    http://www.greenhulk.net/forums/show...highlight=blue

    ignore the carb stuff

    also you would need to add an EFI controller

  10. #10

    Join Date
    Sep 2007
    Location
    New Jersey
    Posts
    8
    Thanks for your help, what are some of the free mods that I can do myself.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with super slow, wet ultra lx
    By JohnnyG. in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 03-02-2013, 06:04 PM
  2. Need help RXP running slow
    By enemozo in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-15-2010, 10:04 PM
  3. Need help impeller too tight!!!!!
    By RocketmanRod in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-29-2010, 10:30 PM
  4. need help *gpr* aftermarket bilge install..
    By HallPass in forum Yamaha Open Discussion
    Replies: 16
    Last Post: 09-03-2007, 02:37 PM
  5. need help *gpr* aftermarket bilge install..
    By HallPass in forum Yamaha How To & FAQs
    Replies: 16
    Last Post: 09-03-2007, 02:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •