Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    XLTNoob
    Join Date
    Jul 2007
    Location
    Baytown, TX
    Posts
    400

    Red face Cavitation problems on holeshot

    Not actually worried about remedying the problem until I get the Sept. 29th ride out of the way, but does this look like a problem?




    My ski's having a hard time hooking up on holeshot(moderate cavitation).. but top end is fine.

    Just trying to figure out where to start looking.
    Last edited by Jolly Roger; 09-17-2007 at 07:05 PM.


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    There seams to be quite a bit of sunshine at your impeller clearance...

  3. #3
    XLTNoob
    Join Date
    Jul 2007
    Location
    Baytown, TX
    Posts
    400
    Quote Originally Posted by beerdart View Post
    There seams to be quite a bit of sunshine at your impeller clearance...
    That's what I thought... I havent stuck a feeler gauge in there yet, gotta take my intake grate off to get at it.. Gimme a sec.

    .021 thousandths between the impeller and the ....wear ring? Pump shoe? What's it called?
    Last edited by Jolly Roger; 09-17-2007 at 07:22 PM.

  4. #4
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Dang,there enough room there,you could throw a cat through it!

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    RREEOOWWWW!!!!

  6. #6
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11

  7. #7
    Psycho

  8. #8
    XLTNoob
    Join Date
    Jul 2007
    Location
    Baytown, TX
    Posts
    400


    Looks like I"m out of spec by like 9 thousandths?
    Surely that couldnt make that big of a difference?

  9. #9
    XLTNoob
    Join Date
    Jul 2007
    Location
    Baytown, TX
    Posts
    400
    Sorry for the image hosting site, I've got a badass popup blocker on firefox and didn't know the site used them..

    To answer some unasked questions, it's an unsealed stock pump with a stock prop.

  10. #10
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Quote Originally Posted by fuxxy View Post


    Looks like I"m out of spec by like 9 thousandths?
    Surely that couldnt make that big of a difference?
    So you are at .027 per side that is .054 overall that is large..

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cavitation on holeshot with VXR?
    By dukenyc in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 09-17-2012, 07:12 AM
  2. 99 Xlt Cavitation Problem
    By hammerdog57 in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 01-25-2007, 01:36 PM
  3. Cavitation Problem? Help!
    By NeverEndn in forum 4-Tec Performance
    Replies: 41
    Last Post: 08-10-2006, 10:01 PM
  4. Bad switch or starter problems on 04 RXP.
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 05-22-2006, 12:53 PM
  5. Mysterious problem on my RXP
    By Jeff C in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-13-2005, 10:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •