Results 1 to 3 of 3
  1. #1
    rior1's Avatar
    Join Date
    Feb 2007
    Location
    uk ESSEX
    Posts
    356

    carbon seal possibilities

    my ski ran fine before i fitted a ss ring and new impeller now its cavitating real bad really shakes side to side and is letting in water,could i have done something to have caused this when fixing my pump back on like over tighten it ?
    just trying to figure out why it went all of a sudden


  2. #2
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    If up put to much grease in the impller splines it moves the shaft forwards and the top hat doesnt seat on the carbon seal hense lets water in and you get lots of cavitation

  3. #3
    rior1's Avatar
    Join Date
    Feb 2007
    Location
    uk ESSEX
    Posts
    356
    to much greese hey
    whooops
    kinda had to mallet that cone back on with all the greese (please refrain from laughing out loud)


    cheers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 04-02-2014, 07:01 PM
  2. Carbon seal failure, Possible motor damage.
    By Gforce in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-10-2008, 04:03 PM
  3. Is my carbon seal toast?
    By Lurker in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 09-02-2006, 03:47 PM
  4. Problems with carbon seal leaking-- possibly this instead...
    By VFX_Artist in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-20-2006, 09:49 AM
  5. Carbon Seal
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 04-27-2006, 02:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •