Results 1 to 2 of 2

Thread: no spark?

  1. #1

    no spark?

    anyone know what would cause a 1990 waverunner to have no spark? is it a common problem or would it be hard to fix? thanks

  2. #2
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Minden, Nevada, United States
    Do you have another coil box you could try? have you looked at you stator assembly? I had a couple Kawi standups and one of them had a very weak spark.I pulled the stator cover off and found that the o ring failed and took in water,rusting everything inside.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How To: Spark Plugs... Many pics and details
    By Shibby1485 in forum Sea Doo How To & FAQs
    Replies: 60
    Last Post: 07-18-2013, 05:17 PM
  2. How-To: Spark Plugs
    By MikeTrin in forum Sea Doo How To & FAQs
    Replies: 9
    Last Post: 01-23-2009, 05:16 PM
  3. Spark plugs... pictures of old and new, Normal?
    By Shibby1485 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-08-2005, 10:12 PM
  4. Where to buy spark plugs??
    By mgo7483 in forum 4-Tec Performance
    Replies: 33
    Last Post: 07-08-2005, 07:44 PM
  5. Spark Plug gap??
    By Cutter in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-07-2005, 03:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts