Results 1 to 2 of 2

Thread: no spark?

  1. #1

    no spark?

    anyone know what would cause a 1990 waverunner to have no spark? is it a common problem or would it be hard to fix? thanks


  2. #2
    WATER WOODY's Avatar
    Join Date
    Aug 2005
    Location
    Minden, Nevada, United States
    Posts
    10,664
    +1
    11
    Do you have another coil box you could try? have you looked at you stator assembly? I had a couple Kawi standups and one of them had a very weak spark.I pulled the stator cover off and found that the o ring failed and took in water,rusting everything inside.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No spark and water temp alarm
    By ybnormal in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-02-2009, 11:02 AM
  2. Engine cranks - but no spark
    By croskel in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 07-12-2006, 01:36 PM
  3. No Spark Help
    By mt375hp in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-27-2006, 04:07 AM
  4. No Spark ?
    By OsideBill in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-07-2006, 03:27 AM
  5. Uncovered my GTX today, has no spark.
    By ccassone in forum Sea Doo Open Discussion
    Replies: 33
    Last Post: 03-27-2006, 09:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •