Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    stepjl's Avatar
    Join Date
    Aug 2007
    Location
    Martinsburg, WV USA
    Posts
    78

    Installing WaveEater Clips on 2001 GP1200...Oil build up in PV Normal?

    After taking off covers to power valves, noticed a lot of oil and oil residue inside of the valve/pin area. Ski has 82hrs, and covers have never been off.... Is this normal?


  2. #2
    MPower's Avatar
    Join Date
    May 2005
    Location
    Raleigh, NC
    Posts
    3,338
    +1
    121
    Yeah that is normal, especially with Yamalube. Just give em a good cleaning.

  3. #3
    subarupartsdude's Avatar
    Join Date
    Jun 2006
    Location
    Norfolk,Va
    Posts
    591
    ^ ditto.......

  4. #4
    stepjl's Avatar
    Join Date
    Aug 2007
    Location
    Martinsburg, WV USA
    Posts
    78

    What is the proper way to clean the valves?

    Quote Originally Posted by subarupartsdude View Post
    ^ ditto.......
    I cleaned the covers, and used a small screwdriver and rag to clean them up best I could. Are you suppose to take the valve assy completely out?? for proper clean up?

  5. #5
    subarupartsdude's Avatar
    Join Date
    Jun 2006
    Location
    Norfolk,Va
    Posts
    591
    What you did is perfectly fine....no need to take the valve out.

  6. #6
    stepjl's Avatar
    Join Date
    Aug 2007
    Location
    Martinsburg, WV USA
    Posts
    78

    Thanks!!

    Quote Originally Posted by subarupartsdude View Post
    What you did is perfectly fine....no need to take the valve out.
    Thanks for the info... I need to get a shop manual...

  7. #7

    Join Date
    Aug 2007
    Location
    Tucson, AZ
    Posts
    54
    Quote Originally Posted by stepjl View Post
    Thanks for the info... I need to get a shop manual...
    Right here. http://greenhulk.net/forums/showthread.php?t=9546

  8. #8
    Mr Waverunner's Avatar
    Join Date
    Sep 2007
    Location
    Central Fla
    Posts
    146
    +1
    2
    Quote Originally Posted by stepjl View Post
    After taking off covers to power valves, noticed a lot of oil and oil residue inside of the valve/pin area. Ski has 82hrs, and covers have never been off.... Is this normal?
    My 2002 XLT 800 looked just like that, except on the forward PV case I found what it looks like a little bit of water (condensation maybe ?)

  9. #9
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    ditto^

  10. #10
    Mr Waverunner's Avatar
    Join Date
    Sep 2007
    Location
    Central Fla
    Posts
    146
    +1
    2
    Quote Originally Posted by RX951 View Post
    ditto^
    Will this create any problem on the PV and components or maybe there is a periodic maintenance for this?
    I can't find any info in the service manual as far as condensation on the PV cases.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil building up in coolant bottle
    By Waterholics in forum 4-Tec Performance
    Replies: 12
    Last Post: 12-18-2012, 08:32 PM
  2. What is the procedure to install waveeater clips on a 98 GP800?
    By dalepatter in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 06-06-2012, 08:05 PM
  3. Installed WaveEater clips, Now no holeshot
    By codemanrose in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 08-01-2010, 09:28 PM
  4. My GP1200 65U build-up
    By Metal4130 in forum Yamaha Old School Skis
    Replies: 49
    Last Post: 09-23-2009, 12:00 PM
  5. Installed WaveEater clips and....
    By emcewin in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 03-22-2008, 08:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •