Results 1 to 4 of 4
  1. #1

    Check ENG P-1202

    Hi all,
    My 04 gtx sc gets this CHK ENG error alot and it happens during in a midle of ridding or idling. Once i get the error my ski stops working and the only way i can get it back to work is to shut down completly. I check the diag code and it says the following. i was wondering if anyone expirence this problem and what was the fix and also how much to get it fix.

    Possible Cause:
    Damaged oil presure switch, blow by valve failure, damage circuit wires, damage connectors or ECM pins.


    Thanks
    db


  2. #2

    Join Date
    Sep 2007
    Location
    sarnia ont
    Posts
    37
    change the pressure swith mounted on the front of the oil seperator just below the oil filler neck. that should fix your problem.

  3. #3

  4. #4
    Quote Originally Posted by db21 View Post
    Hi all,
    My 04 gtx sc gets this CHK ENG error alot and it happens during in a midle of ridding or idling. Once i get the error my ski stops working and the only way i can get it back to work is to shut down completly. I check the diag code and it says the following. i was wondering if anyone expirence this problem and what was the fix and also how much to get it fix.

    Possible Cause:
    Damaged oil presure switch, blow by valve failure, damage circuit wires, damage connectors or ECM pins.


    Thanks
    db

    Thanks Guys... i will check it this weekend and let you know.

    db

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Check Eng Light flashes -runs ok
    By towncarbutch in forum MSX/Matrix
    Replies: 11
    Last Post: 06-23-2015, 08:03 AM
  2. 2006 rxp check eng
    By noddy_o in forum 4-Tec Performance
    Replies: 9
    Last Post: 01-18-2015, 10:51 AM
  3. 05 rxp shut down CHECK ENG LIGHT ON help please!
    By scartigue in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-31-2011, 05:14 AM
  4. Check eng problem???
    By CRS in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-14-2006, 07:41 PM
  5. Installed the Stage1 and my check enging light came on...
    By Denali44 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 04-16-2006, 11:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •