Results 1 to 7 of 7
  1. #1
    GDM's Avatar
    Join Date
    Apr 2007
    Location
    Ahead Of You
    Posts
    389

    Im Back - Blown Supercharger

    .

    i just got my ultra 250 back yesterday .

    it seems a bolt came loose inside the supercharger and ate everything up inside and then blew a hole threw the side of the supercharger

    i was real pissed at kawasaki for taking well over a month to send the supercharger , it was on back order

    i rode it yesterday and it semmed to be running real strong . i had a new sc belt put on and a valve adjustment and spark plugs


    i just ordered the riva rideplate i want to get this tank running 70 plus


    .
    Last edited by GDM; 09-21-2007 at 09:23 AM.


  2. #2
    Silence! I Keel You! earthshaker's Avatar
    Join Date
    May 2007
    Location
    Northern CA Coast
    Posts
    1,616
    +1
    2
    Glad to see ya back up and running! We seem to have lost big red monster too.

  3. #3
    Good to have ya back.

  4. #4
    New to this site and the world of PWC's so I am a rookie to all of this

    I was thinking about getting the SC kit from R&D and was looking in my engine area yesterday and removed the belt cover and tried to spin the SC pulley by hand and it didnt budge ....Should it have
    Last edited by Ultra250xryder; 09-21-2007 at 07:16 PM. Reason: spelling

  5. #5

    Join Date
    Jan 2007
    Location
    Georgia
    Posts
    20
    +1
    1
    Quote Originally Posted by Ultra250xryder View Post
    New to this site and the world of PWC's so I am a rookie to all of this

    I was thinking about getting the SC kit from R&D and was looking in my engine area yesterday and removed the belt cover and tried to spin the SC pulley by hand and it didnt budge ....Should it have
    no

  6. #6
    Quote Originally Posted by JWilson View Post
    no
    Ok thanks man !

  7. #7
    What did your blown supercharger sound like b4 it went out ?

    I noticed a chattering sound in my supercharger yesterday and around 4,000rpms

    And I am only getting 10psi....With the R-Rated BOV block off ....So I think my supercharger is going out

    I think its time to revert it back to stock and take it to the dealer

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. im back
    By daverxp4 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 04-03-2009, 03:34 PM
  2. Blown Supercharger Gear
    By superblownrxp in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-25-2008, 09:21 PM
  3. Im Back!!!! (need Hinge Assy.)
    By PWCManiac in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-29-2007, 11:36 AM
  4. IM BACK!!!!! chris from phila aka CRAZEDRXP!!!!!!!!!!!
    By CRAZEDRXP in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 03-14-2006, 06:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •