Page 1 of 3 123 LastLast
Results 1 to 10 of 26
  1. #1
    ramnj's Avatar
    Join Date
    Apr 2005
    Location
    New Jersey
    Posts
    1,716

    OPAS Removed, What sponsons are you using?

    For those that have removed their OPAS, what sponsons are you using?

    Thanks,


  2. #2

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,986
    +1
    1,900
    Tried the WORX... they are okay, but just bolted a set of the Riva's up and love them. The quality difference is night and day.

  4. #4

    Join Date
    Dec 2005
    Location
    tarpon sp. fl.
    Posts
    35
    riva

  5. #5
    R&D G-Force Sponsons...PR...

  6. #6
    ramnj's Avatar
    Join Date
    Apr 2005
    Location
    New Jersey
    Posts
    1,716
    I thought more people had taken their OPAS off.

    I'm going to go with the Riva sponsons.

  7. #7
    anyone running aggresor?

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,986
    +1
    1,900
    I tried to order a set of R&D sponsons on Friday for a customer and they told me they discontinued them due to low sales volume.... WTF?

  9. #9
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    i removed OPAS.... but still use the stock sponsons... i was gonna put them on my next to do list until i heard Lemoine uses stock sponsons on his race ski

  10. #10
    Quote Originally Posted by Green Hulk
    I tried to order a set of R&D sponsons on Friday for a customer and they told me they discontinued them due to low sales volume.... WTF?

    WOW I guess that would suck if I need any repalcement parts!...PR...

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yami 1.8 L owners, what tool are you using to remove and replace your oil filter?
    By Jarrett in forum Yamaha PWC Performance (4-stroke)
    Replies: 28
    Last Post: 07-12-2012, 05:28 AM
  2. What wax are you using ?
    By MIARider in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 11-02-2007, 12:34 PM
  3. What impeller are you using?
    By xlint89 in forum Polaris PWC Performance
    Replies: 35
    Last Post: 10-28-2007, 11:23 AM
  4. What wax are you using ?
    By MIARider in forum 4-Tec Performance
    Replies: 10
    Last Post: 10-24-2007, 02:26 PM
  5. What oil are you using?
    By Beagleman62 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 19
    Last Post: 07-11-2007, 01:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •