Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    9,966
    +1
    774

    Testing the RRIC with the SOLAS sunday.

    Well I played with the RXP all day today to get it ready for a ride with some GPR guys at my local lake.. Everytime they go I can't make it because I am sitting the kids and they just say I am scared of there STOCK GPRs.. Yea stock and they say this...

    Well I installed My Solas 14-19 GH pitch and the boost gauge. So with this and the RRIC I tested last weekend I bet they just get speachless when we play on sunday...

    Next SCer going to Jerry for my SCer washers and Vortec..

    I am looking for a 73MPH ski sunday...

    Still have my 4inch intake to do aswell. This is all on the work bench and I just don't have anytime to do it...Working my ass off and loveing the kiddo's..


  2. #2
    You will blow them away. With my 05 rxt when it had just an exhaust mod got about a boat ahead of my friends gpr 1300 after about 30-40mph. He never got out in front of me from the holeshot on.
    His stock gpr also only went 59 on the gps.

  3. #3
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    9,966
    +1
    774
    59 mph??? Something is wrong with it. The first model 1300rs went 64-65 and the new one's 66... WOW you might want to tell him something is wrong.. All of the guys I run with are an average of 64mph with there stock 1200 1300r's.

  4. #4
    He is like 6'6 280.. maybe that has something to do with it.

    When his son rides it we are about even in choppy water. So it was probably going about 64-65.

    We are going riding together again april 28th. I'm hoping I'll have my impeller back from impros... See what a rxt stage 2 will do alongside it.

  5. #5
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    9,966
    +1
    774
    Ah OK that is probably it..

    .

  6. #6

    Join Date
    Jun 2005
    Location
    near detroit michigan
    Posts
    299
    I BEAT A RIVA STAGE 1 1300R WITH A BONE STOCK RXP IN 2004 u WILL KILL THEM IF THIER STOCK!!!!!!!!!

  7. #7

    Join Date
    Jul 2005
    Location
    Lake Dunlap, Texas
    Posts
    1,590
    +1
    27
    Austin--What lake you going to? Might want to join you guys if its not Canyon.

  8. #8
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    9,966
    +1
    774
    Ray it is gonna be Canyon, but just for 2 hours and I got to get back to the wife and kids. Don't worry your on my list!!! I want to stop in and see the black beauty in action.

    .

  9. #9

    Join Date
    Jul 2005
    Location
    Lake Dunlap, Texas
    Posts
    1,590
    +1
    27
    Looking forward to meeting you. Keep us posted on your Canyon results. Good hunting.

  10. #10
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    9,966
    +1
    774
    Well I tested the Solas today and it is a nice prop, but I was cavitating bad.. I had to do a rolling start at about 30mph anything less and it would just spin. I pull the pump and couldn't find anything wrong.

    Only thing I could think of is the Seal was crimped over a little...

    Brand NEW wear ring went in with The prop, so no it is not that...



Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is anyone using the nosecone with the Solas?
    By OutlawGPR in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 06-24-2016, 04:10 PM
  2. I tested the bored throttle body
    By Green Hulk in forum 4-Tec Performance
    Replies: 78
    Last Post: 01-17-2009, 03:08 PM
  3. I tested the Riva intercooler today
    By Green Hulk in forum 4-Tec Performance
    Replies: 36
    Last Post: 01-01-2006, 07:53 PM
  4. I tested the new Solas 15/20R today
    By Green Hulk in forum 4-Tec Performance
    Replies: 54
    Last Post: 08-19-2005, 09:29 AM
  5. Thought I lost the Clutch Sunday???
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-16-2005, 01:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •