Results 1 to 9 of 9
  1. #1

    Angry 1994 SL 750 - Running Lean

    Hello All,

    I have been reading your post for the past few months and I have received some great information. Now I need your HELP!

    When we bought the ski (1994 SL 750) it was running great for about 3 months then the problem started. It would bog when taking off, but when holding the choke open it would go. I have read the posts on the subject, I check the Reeds and the reeds were broke in the middle carb. Ordered new reeds and replaced and that did the trick. Now we are having issues after taking off it bogs however if you pull up on the choke it will run in a straight line for a little bit.

    Now this is what else we have done, rebuilt the carbs, no major issues, new diagphrams, new fuel pump (not a triple), replaced spark plugs, compression check 120 ct, 115 aft, 115 front, and the crank index is fine.

    It is still running lean, after putting it to factory spec on the carbs. I have tried to adjust it to a quarter more open and no help.

    Next step we have sprayed starting fluid into the carbs while running and it runs like it is brand new.

    Please help!

    Thanks everyone

    Whitey770


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Welcome to the Hulk!!

    Have you checked the fuel lines? Check the lines that run from the fuel pick-up to the bottom of the tank. The 1994's have screens on them and fill with crap...

  3. #3
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Check also the pulse line from the engine to the pump.If it's cracked It will allow the engine to suck air and also create low fuel pumping.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Do a leak down test. It will tell you if you're sucking air.

  5. #5
    Well we went ahead and looked at the fuel lines and the screens were fine no build up. Checked the pulse line to the engine that was fine. No cracks. H

    How do you do a leak down test?

    Thanks again for the help

    Whitey770

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Seal up the exhaust pipe and carbs air-tight. Then apply 9 psi or vacuum to the pulse fitting. It should hold for a few minutes. If it doesn't, you have an air leak. Use soapy water to help locate the leak. Most common spots are the crank seals and intake area gaskets.

  7. #7
    Ill try that this morning and see what we get ill let you know. Thanks again.

    Whitey770

  8. #8
    Well its been awhile but i think we finally figured it out. The problem ended up being the O-rings around the needle and seat. What a pain. We took apart just about everything on that ski and it turned out to be o-rings. O well just in time to enjoy the nice 90 degree weather here in Cleveland tomorrow.

    Thanks agian guys for all who helped. See you at the bar at Whiskey Island or Geneva on the Lake.


    Whitey770

  9. #9
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Whitey where do you ride? I'm usually at Fairport Harbor...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 SL 750 Pentigon Fuel Pump & Fuel Restrictor Size?
    By joeyjunio in forum Polaris Open Discussion
    Replies: 8
    Last Post: 09-23-2007, 03:26 PM
  2. 1994 SL 750 Timing?
    By Playtime in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-18-2007, 08:14 AM
  3. More MPH on a stock 1994 SL 750
    By jmule98 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 06-27-2007, 06:44 PM
  4. 1994 Sl 750 Regulator and spark
    By Playtime in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-16-2007, 12:40 AM
  5. 1994 sl 750 plumbing problem
    By roushski in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 04-03-2007, 03:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •