Results 1 to 3 of 3

Thread: tach problem

  1. #1

    Join Date
    Sep 2007
    Location
    albany, ga
    Posts
    129

    tach problem

    have a new speedster 200...430.....first time out on boat ( about three weeks ago ) tach quit working.....so i pulled the key and refired boat...all o.k. until last nite...same thing happenned.....this has only happened 2 time but i do have some concerns......any help on this would be appreciated...thank you


  2. #2
    cyoungesq's Avatar
    Join Date
    Apr 2006
    Location
    Bridgeport, CT
    Posts
    217
    not uncommon. source of problem unknown. Many (myself included) have experienced the same thing.

  3. #3
    spd5535's Avatar
    Join Date
    Jun 2007
    Location
    MN
    Posts
    263
    Same here on my Utopia........

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Weird Tach problem on 1996 GTX
    By kclements in forum 2-Stroke Performance
    Replies: 0
    Last Post: 08-22-2015, 11:36 AM
  2. Tach problem
    By silver93t in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 08-06-2015, 01:28 PM
  3. Tach problem 2007 fx ho
    By snakeoil in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 03-29-2015, 12:18 PM
  4. Tach problem
    By MGROLES in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-26-2013, 12:51 PM
  5. Tiny Tach problems
    By Tommy Pantsdown in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 07-03-2012, 03:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •