Results 1 to 8 of 8
  1. #1
    Banned User
    Join Date
    Sep 2007
    Location
    USA
    Posts
    22

    Hard starting GSX RFI

    My GSX RFI starts fairly easy when cold but it when it's warm it takes a lot of cranking to get it going. It also goes through a set of plugs about every tank of gas. I use the right Sea Doo oil. Any ideas???


  2. #2
    Banned User
    Join Date
    Sep 2007
    Location
    USA
    Posts
    22
    Any one have an idea???

  3. #3
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    It should not foul plugs. After verifying the inlet strainer from the fuel tank is clean then there is not much you can doo other than take it to the dealer for diagnosis. That's unfortunately the down-side of fuel injection...

  4. #4
    Sounds like you may have some leaky injectors.

  5. #5

    Join Date
    Dec 2006
    Location
    Cartersville, GA
    Posts
    59
    Rotary valve clearance is too loose. Get the cover machined for minimum clearance. Make sure the machining grooves go up and down. Problem solved.

  6. #6
    Banned User
    Join Date
    Sep 2007
    Location
    USA
    Posts
    22
    Please explain this to me. I am an idiot when it comes to valves

  7. #7

    Join Date
    Dec 2006
    Location
    Cartersville, GA
    Posts
    59
    You must remove the rotary valve cover and check the clearance with solder as per the SeaDoo manual. Measure the "squished" solder, that is the clearance. It must be at the Minimum per seadoo specs. Hard starting when hot and good starting when cold is almost ALWAYS a rotary valve issue. Unless this thing has 350+ hours on it......More like 450+ but anyway......

  8. #8
    Banned User
    Join Date
    Sep 2007
    Location
    USA
    Posts
    22
    Thanks... I know what you are talking about now. I can do this no problem. I should have thought of this. I have seen the same problems with Honda motocross bikes.

    The machine has about 300 hours on it. It started doing this about 10 hours ago.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 gsx rfi hard to no start on water. please help!
    By jammin777 in forum 2-Stroke Performance
    Replies: 61
    Last Post: 07-06-2015, 12:49 AM
  2. 1999 Seadoo GSX RFI Extremly hard start in water.
    By RightsaidFred in forum 2-Stroke Performance
    Replies: 14
    Last Post: 07-16-2014, 09:01 AM
  3. 99 GSX RFi won't start
    By monchy12 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-27-2012, 09:30 AM
  4. 2000 gsx rfi not starting!
    By donahue_85 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 10-15-2010, 01:02 PM
  5. 1999 GSX RFI hard starting in water
    By JonnyRXT in forum 2-Stroke Performance
    Replies: 5
    Last Post: 08-06-2010, 08:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •