Results 1 to 7 of 7

Thread: RXP S1 RPM's

  1. #1
    blowbyu's Avatar
    Join Date
    Jun 2006
    Location
    San Antonio, TX
    Posts
    635

    RXP S1 RPM's

    I currently have the following installed on my 2006 RXP.

    Riva Grate
    Rivia Rear Intake
    SS Wear Ring

    Was hitting 8120 @ 70+ in 80 degree weather.

    In the previous weeks the current temps have been high 90's and was running 7920 @ 69+.

    Now this past weekend I installed a 14-19r on the ski and I can say the hookup and acceleration is better, however my rpms are now down 100rpm (which they should be considering it's a larger prop)

    Temps were low 90's.
    RPM's/Speed now is 7840 @ 69+

    What I'm wonder is.....are most of you all loosing 200-300rpms due to heat?
    Last edited by blowbyu; 10-01-2007 at 07:02 PM.


  2. #2
    cbrich's Avatar
    Join Date
    Nov 2006
    Location
    Around Lake Travis
    Posts
    1,374
    +1
    1
    I was seeing 8,060-8,100 this past weekend at Travis.

  3. #3
    Big K's son KeithKman's Avatar
    Join Date
    Dec 2006
    Location
    Southern California
    Posts
    1,735
    Shot answer, yes. My mods are in my sig.

    I was running 7900 rpm in 110 degree heat and the water was in the high 80's. I would be running around 68 mph.

    Last weekend the water was 77 degrees, air was 75 degrees. I got 8050 rpm at 70.9 with an almost full tank of gas (-2 bars).

    Last January when the water was 50 degrees and the air was 45 degrees I was getting 8150 rpm. I forget my top speed last winter.

  4. #4
    blowbyu's Avatar
    Join Date
    Jun 2006
    Location
    San Antonio, TX
    Posts
    635
    Quote Originally Posted by cbrich View Post
    I was seeing 8,060-8,100 this past weekend at Travis.
    Hmmmm same air temps same humidity. Clay, what are your mods in that RXT?

    Robert

  5. #5
    blowbyu's Avatar
    Join Date
    Jun 2006
    Location
    San Antonio, TX
    Posts
    635
    Going to check the slip on the supercharger as I cant see me being 250 rpms down due to heat. With my mods i should be pushing a untouched 14-19r at least 7950 rpms in 90 plus degrees.

    Any of you other guys running a stage 1 having to depitch the 14-19r?

  6. #6
    cbrich's Avatar
    Join Date
    Nov 2006
    Location
    Around Lake Travis
    Posts
    1,374
    +1
    1
    Quote Originally Posted by blowbyu View Post
    Hmmmm same air temps same humidity. Clay, what are your mods in that RXT?

    Robert
    Steel Washers
    4" Intake
    Riva Rear Exhaust
    Wedge
    Grate

    I believe that is it .

  7. #7
    blowbyu's Avatar
    Join Date
    Jun 2006
    Location
    San Antonio, TX
    Posts
    635
    So Water4fire came over to my house last night and we did a slip test on the supercharger and it reads 50-55 LBS of slip. So I guess this is the reason I am down about 300rpms on top. Orderd new spring washers from greenhulk....I wish I could get next day air
    Last edited by blowbyu; 10-12-2007 at 11:01 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP lost rpms
    By RedRyderRXP in forum Sea Doo Open Discussion
    Replies: 28
    Last Post: 07-13-2006, 12:59 AM
  2. RXP 8000 RPM with mods
    By RXP04 in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 06-03-2006, 01:57 PM
  3. RXP/RXT RPMS
    By 12timeworldchamps in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-14-2006, 11:33 PM
  4. RXP Rotax RPM problem... we're helpless
    By Shibby1485 in forum 4-Tec Performance
    Replies: 13
    Last Post: 08-28-2005, 08:05 PM
  5. New 04 RXP Low RPM & Speed
    By RXP04 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-02-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •