Results 1 to 3 of 3
  1. #1

    Virage Txi Probs!!! Suggestions!

    My motor runs great...except when i go to get on the throttle the impeller wont move...it was working fine and then diw(deadin water)...and also any one know of simple cost effective upgrades?


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    You might have bad coupler.

  3. #3
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    Have you found the cause of your problem ?if so let us know if you will .Helps us help others ,which includes you

    Cheers

    Bernie

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 02 Virage TXi Backfire
    By sammer77 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-07-2007, 04:30 PM
  2. 2002 Polaris Virage TXi.. HELP!!! WON'T START
    By fitch615 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-05-2007, 04:31 PM
  3. 2001 Polaris VIRAGE TXI performance upgrades?
    By john8873 in forum Polaris PWC Performance
    Replies: 7
    Last Post: 03-08-2007, 06:36 PM
  4. Virage txi Giving me trouble
    By Mauivirager in forum Polaris How To & FAQs
    Replies: 21
    Last Post: 12-19-2006, 06:21 PM
  5. virage txi help
    By superduty in forum Polaris PWC Performance
    Replies: 4
    Last Post: 09-11-2006, 04:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •