Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    Just Back From Lake. Bad Stuff Going On! Help

    Just Got Back From Lake 1 Hour Ago. Here Is Story And The Problem. First Ski Is A 2004 Rxp With Riva Stg 1. Rpms At 8050 And Running Great. Has 77 Hrs. Was Out Riding Today And After About 1 Hour Of Runnin. I Made A Long Hard 55mph Turn With Trim Down. And Then It Happened, I Heard A Thud. Went To Stop Then Go Again Wont Go At All Like It Was Cavatating Real Bad!(at That Point I Shut It Down And Towed It Back To Trailer. Got On Trailer And It Was Full Of Water For One, Started It Up And Runs Fine My Motor And Supercharger Seems Okay After A Couple Rev Tunes. My Ski Never Has Water In It, Never A Drop. There Was Tons In It. Any Ideas Were I Should Start


  2. #2
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Crawl under your ski. See if the intake grate is still there.

    Otherwise I'd look to see if the driveshaft seal is leaking.

  3. #3
    suck my wake's Avatar
    Join Date
    Apr 2006
    Location
    Sugar Grove IL
    Posts
    2,872
    +1
    12
    Quote Originally Posted by TDSTYG View Post
    Just Got Back From Lake 1 Hour Ago. Here Is Story And The Problem. First Ski Is A 2004 Rxp With Riva Stg 1. Rpms At 8050 And Running Great. Has 77 Hrs. Was Out Riding Today And After About 1 Hour Of Runnin. I Made A Long Hard 55mph Turn With Trim Down. And Then It Happened, I Heard A Thud. Went To Stop Then Go Again Wont Go At All Like It Was Cavatating Real Bad!(at That Point I Shut It Down And Towed It Back To Trailer. Got On Trailer And It Was Full Of Water For One, Started It Up And Runs Fine My Motor And Supercharger Seems Okay After A Couple Rev Tunes. My Ski Never Has Water In It, Never A Drop. There Was Tons In It. Any Ideas Were I Should Start
    Check your waterbox and make sure you didn't pop it somewhere and then make sure the carbon seal is ok

  4. #4
    I Checked Grate It Is Still There And Tight. Looked In Pump And Prop Looks Fine. I Will Check Water Box. What Is A Carbon Seal?

  5. #5
    Say Drive Shaft Seal Is Bad Or Carbon Seal Is Bad. Why Does It Not Want To Go And Cavatate So Bad

  6. #6
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by TDSTYG View Post
    Say Drive Shaft Seal Is Bad Or Carbon Seal Is Bad. Why Does It Not Want To Go And Cavatate So Bad
    Its sucking air past that carbon seal. Causing your cavitation. Then when the ski isnt running, water is coming in past that seal.

  7. #7
    Where Is That Carbon Seal At? I Will Take Pump Out Tomorow. And Do They Make A Better Replacement?

  8. #8
    cbrich's Avatar
    Join Date
    Nov 2006
    Location
    Around Lake Travis
    Posts
    1,374
    +1
    1
    Pull your pump and check the impeller, you might have picked up a small chuck of wood, this could cause the horrible cavitation. The water could have gotten in because you forgot to screw the drain valve back in, which is not a big deal since the drain valves have an automatic closing devise (ball and seat), but there was crap in the ball and seat and you took on water.

  9. #9
    Well I Pulled Pump And Took Off My Intake So I Could See And There Was A Busted O Ring, The Rubber Boot Was Loose And I Am Looking For The Carbon Ring Right Now

  10. #10
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Here is where the carbon ring is:
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	carbon.JPG 
Views:	76 
Size:	15.3 KB 
ID:	40832  

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Back from Lake, Grate is gone
    By bcromwell in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 06-13-2010, 11:14 AM
  2. Gas in Oil, just back from dealer
    By john87rico in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 09-06-2007, 09:21 PM
  3. Gas in Oil, just back from dealer
    By john87rico in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 09-06-2007, 05:20 PM
  4. Just back from powder coating take a look
    By mikegpr03 in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 11-21-2006, 12:23 AM
  5. Just back from Testing RXT
    By Shibby1485 in forum 4-Tec Performance
    Replies: 27
    Last Post: 12-12-2005, 05:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •