Results 1 to 5 of 5
  1. #1

    1998 1100 STX trouble under load

    Hi Guys,

    I'm a complete newbie to the entire Jetski World. Just purchased a 1998 1100 stx, had a tune up done on it, and partial carb rebuild as well.

    The dealer claimed it ran great, so i took it to the lake.

    My maximum rpm in the water was 4000. Getting there was a challenge, but it really seemed like it was struggling, just plowing through the water at no more than 20mph.

    Tried a few things, spark etc and ran it on the hose. Got up to 8000 rpm no problem (thats the limit set on these right?)

    Took it back to the lake to try it out and I'm back to the 4000 rpm limit.

    So any ideas what can be causing the rev limit while under load only? Running fine on the hose suggests to me the engine/carbs are fine right?

    Like i said pretty new to this stuff, but I'm fairly mechanical so I'm willing to play with it.

    Hope you can help me out!

    Thanks,

    John


  2. #2
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Sounds like you could have a fouled plug. Run it for a bit then feel the plug bases the bad one will be noticeably cooler. Another possible cause would be a bad fuel pump or cracked pulse line.

  3. #3
    Quote Originally Posted by btldigger View Post
    Sounds like you could have a fouled plug. Run it for a bit then feel the plug bases the bad one will be noticeably cooler. Another possible cause would be a bad fuel pump or cracked pulse line.

    i checked spark on each plug individually and each cylinder fired, so I'm thinking all the plugs should be good (they are all less than 1hr odl, probabaly less than 20min)

    does the engine demand that much mroe fuel under load that the fuel pump would be adequate for running on land but not enough while in the water?

  4. #4
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Quote Originally Posted by johng87 View Post
    i checked spark on each plug individually and each cylinder fired, so I'm thinking all the plugs should be good (they are all less than 1hr odl, probabaly less than 20min)

    does the engine demand that much mroe fuel under load that the fuel pump would be adequate for running on land but not enough while in the water?
    Yes it would take more under load. It will hit the rev limiter on land running on 2 cylinders. Mine was running bad at the start of the season, found a hole in the fuel pump diaphram. It would still rev right up on the trailer.

  5. #5

    fuel

    any idea what the fuel pressure should be on these? I can check that and decide where to go from there. I did notice that my cv slides weren't functioning at all, and trying to check for some type of vacuum leak now.

    thanks again,

    John

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 1100 stx electric issue
    By murdo6 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 19
    Last Post: 11-08-2016, 10:21 PM
  2. 1998 1100 stx won't idle
    By bhale5 in forum Kawasaki How To & FAQs
    Replies: 9
    Last Post: 08-25-2012, 01:34 PM
  3. 1998 1100 stx oil pump question
    By bmxican in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-15-2012, 10:45 PM
  4. 1998 1100 STX foul plugs
    By bob123 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-22-2009, 11:36 PM
  5. 1998 Kawasaki 1100 STX Complete motor
    By viperjohn in forum Kawasaki Classifieds
    Replies: 7
    Last Post: 05-27-2009, 10:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •