Results 1 to 4 of 4
  1. #1
    PeaceRiverRider's Avatar
    Join Date
    Apr 2007
    Location
    Punta Gorda, Florida, United States
    Posts
    52
    +1
    1

    Genesis Won't Start

    I have a 2002 fuel injector Genesis. The last time I took it out it ran fine. I had it on a floating dock and last week I went to take it out and it wouldn't start. I took it out and put in my garage with the seats off, hooked up the battery tender,ordered new plugs. I tried to start it again today and it still won't start. The plugs are getting fuel and spark but it just won't start. It cranks but it just won't start. Any suggestions?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,588
    +1
    1,272
    Quote Originally Posted by PeaceRiverRider View Post
    I have a 2002 fuel injector Genesis. The last time I took it out it ran fine. I had it on a floating dock and last week I went to take it out and it wouldn't start. I took it out and put in my garage with the seats off, hooked up the battery tender,ordered new plugs. I tried to start it again today and it still won't start. The plugs are getting fuel and spark but it just won't start. It cranks but it just won't start. Any suggestions?
    Others here have had similar problems. Search through the forum for those posts.

    I think I recall that unplugging the TPS (Throttle Position Sensor) sensor can tell you if the TPS is causing the problem.

    Read through the forum, and others who have these injected motors are likely to jump in with their advice.

  3. #3
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Check your battery voltage with a volt meter while cranking.

    Also, in the tech section there is a manual for your ski. Check in the back, there is a starting troubleshooting guide for the FI skis. Alot of good info there.

    Let us know what you find.

    -Rob

  4. #4
    I had the same problem on my 02 virage, it was the starter solenoid. 43 bucks fixed it.



    On a side note Advance Auto Parts carries the stock numbered NGK plugs for Polaris' for 1.48 a piece, they were 4.90 a piece from the dealer.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help - genesis won't start
    By sdrake in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-17-2013, 08:27 AM
  2. 1999 genesis won't start when hot
    By stump in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-06-2011, 07:10 PM
  3. 00 Genesis Won't Start, No Spark
    By TXRXP in forum Polaris Open Discussion
    Replies: 8
    Last Post: 03-04-2011, 08:15 AM
  4. 2003 Polaris Genesis won't start.
    By toothtech in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 09-13-2009, 08:45 PM
  5. 2001 Polaris Genesis won't start
    By Blink in forum Polaris How To & FAQs
    Replies: 11
    Last Post: 01-11-2007, 09:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •