Results 1 to 8 of 8
  1. #1

    RXP lack of full power until warmed up

    I have a 05 RXP, and RXT. both have the same symptoms. When they are first started, they act like they are running on the learner key. Then as they warm up, they will surge with power Intermittently. It eventually clears up after about 5- 10 minutes of riding. It seems to be worse if it's been a while since I wrode last. They did this a couple of times last year, but this year it has occured more frequently

    Thanks


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by ORL View Post
    I have a 05 RXP, and RXT. both have the same symptoms. When they are first started, they act like they are running on the learner key. Then as they warm up, they will surge with power Intermittently. It eventually clears up after about 5- 10 minutes of riding. It seems to be worse if it's been a while since I wrode last. They did this a couple of times last year, but this year it has occured more frequently

    Thanks

    They are just like a car, gotta let them warm up, ALWAYS......I always idle with my ski for atleast a minute or two, then take off but only go about 1/3-1/2 throttle for atleast another 3-4 minutes before I give it a few whaps and go....

  3. #3

    Join Date
    Jun 2007
    Location
    Mt.prospect IL
    Posts
    92
    wow i didnt know that people did that ..................... ALWAYS LET IT WARM UP!!!!!

  4. #4
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Change the spark plugs.

  5. #5
    Quote Originally Posted by RXP Steve View Post
    Change the spark plugs.
    ditto, I was just going to suggest that...PR...

  6. #6
    THEE 6'5" 235pd rough rider doc212121's Avatar
    Join Date
    May 2007
    Location
    MI
    Posts
    396
    plugs for sure, and give it some time to get warmed up never hurt either! Good luck and report back!

  7. #7
    North Carolina Hoovermaneuver's Avatar
    Join Date
    Apr 2005
    Location
    Benson, NC.
    Posts
    816
    +1
    26
    I never wait 5 to 10 min. I can start mine after sitting for months and hit it full throttle in a minute.

  8. #8
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki STX 15f Loss of Full Power
    By dhart in forum Kawasaki How To & FAQs
    Replies: 6
    Last Post: 10-27-2016, 08:17 AM
  2. Kawasaki STX 15f Loss of Full Power
    By dhart in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-29-2016, 09:59 AM
  3. Virage TXI Won't run until warms up
    By leavundst in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-17-2013, 12:22 PM
  4. Slight hesitation until warmed up- 2002 TXI
    By tabadman in forum Polaris Tech Tips and Info
    Replies: 6
    Last Post: 07-19-2012, 10:01 PM
  5. Loss of full power - Polaris SLT 750 (blue engine)
    By pnyride in forum Polaris Open Discussion
    Replies: 18
    Last Post: 05-22-2012, 09:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •