Results 1 to 7 of 7

Thread: solas question

  1. #1

    solas question

    looking through my intake grate i noticed that i can turn the green nut infront of the solas prop with my hand. i turn it counter clockwise and clockwise and it just dose not lock completly in any direction. is this normal.


  2. #2
    Senior Member watermedic's Avatar
    Join Date
    Apr 2005
    Location
    West Virginia
    Posts
    383
    Sounds like the threads stripped on the solas cone. A very typical problem. You can install the stock prop cone if the green one is toast.

  3. #3
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,678
    +1
    3

    Re: solas question

    Quote Originally Posted by Carlos Miami RXP
    ... i turn it counter clockwise and clockwise and it just dose not lock completly in any direction. is this normal.
    Well, yes and no. It has unscrewed itself from the impeller, which is a pretty normal accurance for the green Solas nose cone... but it is not normally left this way. If you drop the intake grate you can usually reach up and turn it "counterclockwise" (left-hand thread) and reseat it. Use a good dose of lock tight.

    Also, use caution the blades are extremely sharp... I know to well

    Jeff

  4. #4
    Thanks guys 1 more thing do i use lock tight on the intake bolts?

  5. #5
    Use red loctite for the impellor cone. Use a good coat of it around the whole thread. Tighten it up by hand as tight as you can. If you want to do it the right way you have to take apart the pump and put a wrench on it. But doing it through the intake grate is much easier. Wipe up any that spills and I would just use a small amount of silicone on the intake grate. You might have to take it out again. Let the whole thing sit for a day or two and it should be good and tight.

  6. #6
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,678
    +1
    3
    I installed over a dozen intake grates for my friends last year and put silicone on all of them but mine... mine is the only one that is now on the bottom of the delta. The ski was almost in the same place... when the front bolt comes out it leaves you with the "hole in the hull from hell"

    Definitately use silicone on the front bolt!

    Jeff

  7. #7
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    Carlos:

    I took the pump off, "Jimied" the threads of the nose cone with a pliars, then put a bead of silicone on the nose cone threads and tightened mine back on.

    It has not budged in 80 hours...........

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Solas Question
    By moultrie rxp in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-25-2013, 09:54 PM
  2. Solas 15/20r pitch question
    By The Bandit in forum 4-Tec Performance
    Replies: 24
    Last Post: 03-31-2007, 05:39 PM
  3. Solas Impeller Question, Help......
    By Tiburon in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-08-2006, 06:39 PM
  4. solas prop question
    By Top banana in forum 4-Tec Performance
    Replies: 0
    Last Post: 09-27-2006, 12:12 AM
  5. Solas impeller question
    By Jeff C in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-03-2005, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •