Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18

Thread: Lost My Skegs

  1. #1
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,627
    +1
    806

    Lost My Skegs

    I had my skegs for a while..Atleast a few months. I used to check every ride to see if they were there because I wasn't confident that they would stick. They always did stick though so I stopped checking. I looked today and they were gone..Wiped clean off the rideplate. I used the recommended epoxy too. It probably had something to do with my 4 degrees of wedge. I guess it's just another excuse to get the rideplate mod done


  2. #2
    My new toys at work bruinsrme's Avatar
    Join Date
    Jul 2007
    Location
    Worcester MA
    Posts
    1,706
    what ride plate mod?

    Can't imagine the alignment needed for that could help myself

  3. #3

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    i've lost mine, one went a bit ago and i had to steer slightly to the left in straight lines to compensate, then the other fell off, i don't really miss them i even belive i'm faster on glass, regards bill

  4. #4
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by JFizzleJR View Post
    I had my skegs for a while..Atleast a few months. I used to check every ride to see if they were there because I wasn't confident that they would stick. They always did stick though so I stopped checking. I looked today and they were gone..Wiped clean off the rideplate. I used the recommended epoxy too. It probably had something to do with my 4 degrees of wedge. I guess it's just another excuse to get the rideplate mod done
    Wow James, I hadn't heard of anyone loosing them...
    How's the 4 degrees working out?? Seems like a high ride...

  5. #5
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    lost my first set too, found that the second time i put them on i used a floor jack to just barely lift the ski on the bottom of the skegs when i put the epoxy on and let it sit like that for about a week, the whole weight of the ski on the skegs, they held all year evev on a dry dock that they rubbed on everytime i pulled up, they actually tore the hell out of the dry dock, haha

  6. #6
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,627
    +1
    806
    Quote Originally Posted by seadoo02xp View Post
    lost my first set too, found that the second time i put them on i used a floor jack to just barely lift the ski on the bottom of the skegs when i put the epoxy on and let it sit like that for about a week, the whole weight of the ski on the skegs, they held all year evev on a dry dock that they rubbed on everytime i pulled up, they actually tore the hell out of the dry dock, haha
    mcrowley did the floor jack trick I believe and didn't have good luck. the one skeg ended up out of place and he had to do it over.. i think i need to glue it better next time. any trick to having the skegs not slide out of place while pressing into them?

    Quote Originally Posted by lafjax View Post
    Wow James, I hadn't heard of anyone loosing them...
    How's the 4 degrees working out?? Seems like a high ride...
    It's fun. I still have to adjust the steering a whole bunch and the reverse linkage as well so I can put my bucket back on. Video is coming soon

  7. #7
    Legend in my own mind Sirhc7897's Avatar
    Join Date
    Aug 2005
    Location
    Lake Butler, FL.
    Posts
    1,140
    My rideplate was apparently much flatter than the one used to meodel the rideplate skegs. Mine initially popped loose on the front (but didn't fall off)...

    To get them to stay I ended up having to machine the skegs down (flatten) to match the curve of my rideplate and they have since held...

  8. #8
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by JFizzleJR View Post
    mcrowley did the floor jack trick I believe and didn't have good luck. the one skeg ended up out of place and he had to do it over.. i think i need to glue it better next time. any trick to having the skegs not slide out of place while pressing into them?
    Mine slide a little too but I backed it off re aligned and very slowly, maybe 1/4 turn at a time, raised the jack to hold, checking after every 1/4 turn. Due to the little bend in the skegs and the ride plate they dried with some small spaces in several places at the contact points. I then took my finger with the marine epoxy and wiped epoxy into those spaces...no problems yet...only been 6 months though (75 hours).

  9. #9
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by JFizzleJR View Post
    any trick to having the skegs not slide out of place while pressing into them?

    I did 1 skeg at a time,But there are some members on here that have taken a piece of wood and cut grooves 5 1/2 inches apart and lifted the skegs with the wood..

  10. #10
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    if you like the skegs that much and want to always have them on your ski and never think twice about them being under there.... take the rideplate off and drill and tap the skeg from between the rideplate halves

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just ordered my skegs!!
    By Alex13 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-27-2006, 10:23 PM
  2. Lost my ignition key, can I use any key?
    By Hecyan in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-09-2006, 08:00 AM
  3. My Skegs
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-10-2006, 11:31 AM
  4. LOST my RXP manual on the computer can someone help?
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 01-21-2006, 10:44 PM
  5. lost my clutch today
    By Green Hulk in forum 4-Tec Performance
    Replies: 30
    Last Post: 06-14-2005, 07:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •