Results 1 to 8 of 8
  1. #1
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77

    Rotax Racing IC - How to find leaks?

    I think my boost is escaping somewhere. What's the best plan of action to hunt that down? Anyone else run into this?


  2. #2
    Therock's Avatar
    Join Date
    Apr 2005
    Location
    Jacksonville,FL
    Posts
    170
    How do you know that your losing boost? Do you have a BOV?

  3. #3
    Jarret- Why do you think you are loosing boost? RPM'S

  4. #4
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    Just a guess really. RPMs are firm at 7650-7700 today in the heat. I get there is a hurry and then just top out. I am assuming that the boost is escaping, but not certain.

    Any ideas?

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,385
    +1
    2,512
    the more i think about it the more i think its the pitch on that solas.

    jarrett, remember when i told you i ordered a new solas from Dave at Impros? Well, i was topped out at 7800 RPM's with that prop. It was pitched at a 14.5/20.

  6. #6
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Jerry, I just looked at mine and it is a 14/20. Don't know what that means, but the stock prop is on and ready for a 6:00 a.m. test run tomorrow

  7. #7
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    Jerry, I wish that was it but in Riva Stage I form, I have run this same prop up to 7900-7950 in Texas heat. I hate to admit it, but at this point I am 300 RPM down after installing the Rotax Racing Stage I.

  8. #8
    rx4pain's Avatar
    Join Date
    Apr 2005
    Location
    Olympia, WA
    Posts
    1,965
    +1
    2
    My problem, as it may be others, is that I put on more than one mod at a time and then when a change in performance for the better or worse is noticed I can't say for sure which alteration I did that caused it. The RR Stage I has many mods...the ECU is what sticks in my mind with the loss in RPM's based on a previous thread I read. Or perhaps you were the one Jarrett that had the dilemma with the RR ECU and was trying to work something out with Mark U.???

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Getting some water in my 2009 FX SHO........how to find the leak????
    By rjharris in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 10-27-2015, 10:01 AM
  2. how need install Rotax Racing IC
    By repsol in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-14-2008, 02:12 PM
  3. Anyone have pics of the Rotax Racing IC mounted ?
    By DaveC in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-18-2007, 06:22 AM
  4. How to find a Competent Seadoo Mechanic
    By Spike in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 10-26-2006, 02:45 PM
  5. Riva vs Rotax Racing kits which to use ?
    By stonylake rxp in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-24-2006, 10:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •