Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1
    SPEED COMES 1/10 @ A TIME SpeedFreeks Racing's Avatar
    Join Date
    Jun 2007
    Location
    BROOKLYN N.Y.
    Posts
    407
    +1
    1

    pump shoe fix /w possible speed gains

    HERE'S HOW I CAME UP WITH A FIX FOR THE HORRIBLE SEA DOO PUMP SHOE. I HAVE FOUND WITH MOST RXT'S/RXP'S THAT THE PUMP SHOE MAY HAVE A BAD BEND IN THE MIDDLE OF THE LEADING EDGE RIGHT WHERE THE INTAKE MEETS THE PUMP SHOE. I HAVE FOUND AFTER FIXING THIS PROBLEM WE HAVE FOUND SOME INCREASE IN SPEEDS, ANYWHERE FROM 0-1+MPH. ALSO WE HAVE FOUND WITH THIS PROBLEM YOUR SKI MAY FEEL LOOSE OR SLOPPY OR MAY RIDE TILTED OVER TO THE RIGHT SIDE. ALSO AS WATER FINDS IT'S WAY INTO THE PUMP SHOE AT SPEEDS IT WILL MAKE THAT HUMP GET MUCH HIGHER AND OBSTRUCT THE FLOW OF WATER ENTERING YOUR PUMP AND ALSO ACTING LIKE A SNOW PLOW SLOWING U DOWN.

    HERE ARE SOME PICS OF MY PUMP SHOE WHEN IT RIPPED OUT AT 77MPH. IT WAS ONE HELL OF A SCARY RIDE

    THE PIC'S WILL TELL IT ALL
    Last edited by SpeedFreeks Racing; 10-15-2007 at 09:30 PM. Reason: ADD PICS


  2. #2
    suck my wake's Avatar
    Join Date
    Apr 2006
    Location
    Sugar Grove IL
    Posts
    2,872
    +1
    12
    I no see no pic's

  3. #3
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by SpeedFreeks Racing View Post
    HERE'S HOW I CAME UP WITH A FIX FOR THE HORRIBLE SEA DOO PUMP SHOE. I HAVE FOUND WITH MOST RXT'S/RXP'S THAT THE PUMP SHOE MAY HAVE A BAD BEND IN THE MIDDLE OF THE LEADING EDGE RIGHT WHERE THE INTAKE MEETS THE PUMP SHOE. I HAVE FOUND AFTER FIXING THIS PROBLEM WE HAVE FOUND SOME INCREASE IN SPEEDS, ANYWHERE FROM 0-1+MPH. ALSO WE HAVE FOUND WITH THIS PROBLEM YOUR SKI MAY FEEL LOOSE OR SLOPPY OR MAY RIDE TILTED OVER TO THE RIGHT SIDE. ALSO AS WATER FINDS IT'S WAY INTO THE PUMP SHOE AT SPEEDS IT WILL MAKE THAT HUMP GET MUCH HIGHER AND OBSTRUCT THE FLOW OF WATER ENTERING YOUR PUMP AND ALSO ACTING LIKE A SNOW PLOW SLOWING U DOWN.

    HERE ARE SOME PICS OF MY PUMP SHOE WHEN IT RIPPED OUT AT 77MPH. IT WAS ONE HELL OF A SCARY RIDE

    THE PIC'S WILL TELL IT ALL
    Pics arent showing.

  4. #4
    SPEED COMES 1/10 @ A TIME SpeedFreeks Racing's Avatar
    Join Date
    Jun 2007
    Location
    BROOKLYN N.Y.
    Posts
    407
    +1
    1

    Forgot Pic's

    Here Are The Pics.....

  5. #5
    suck my wake's Avatar
    Join Date
    Apr 2006
    Location
    Sugar Grove IL
    Posts
    2,872
    +1
    12
    I am thinking I am going blind

  6. #6
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    put down the SPECIAL CIGARETTE or the BEER and POST the pics!

  7. #7
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87

  8. #8
    SPEED COMES 1/10 @ A TIME SpeedFreeks Racing's Avatar
    Join Date
    Jun 2007
    Location
    BROOKLYN N.Y.
    Posts
    407
    +1
    1

    PIC'S

    I'm Trying But I Seem To Be Having Some Trouble.......
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00886.JPG 
Views:	110 
Size:	146.3 KB 
ID:	41868  

  9. #9
    suck my wake's Avatar
    Join Date
    Apr 2006
    Location
    Sugar Grove IL
    Posts
    2,872
    +1
    12
    Now thats some funny chit smilie can't see either

  10. #10
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by SpeedFreeks Racing View Post
    I'm Trying But I Seem To Be Having Some Trouble.......
    Dam. What caused that??? Something that is easily fixed or what?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Speed Needed for Pump Shoe Insert and Girdle kit?
    By skigolfnut in forum 4-Tec Performance
    Replies: 10
    Last Post: 10-08-2011, 03:42 AM
  2. Pump Shoe Inserts ... Possible to Fix?
    By PredHunter in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-07-2010, 12:42 PM
  3. pump shoe broken/fix
    By txgp1300r in forum Yamaha How To & FAQs
    Replies: 2
    Last Post: 05-30-2008, 04:25 PM
  4. Can A Crappy Seal on Your Pump Shoe Scrub Speed?
    By yellow4 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-26-2007, 06:35 PM
  5. Speed Gain Documentation: Stock to Stage 1
    By RXP-REX in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-27-2007, 01:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •