Results 1 to 9 of 9
  1. #1
    Denali44's Avatar
    Join Date
    Jul 2005
    Location
    Maine
    Posts
    125

    Installed the Stage1 and my check enging light came on...

    Had my dealer install the Stage 1 last week. Went out on the lake and it ran great! 10 minutes later the check engine light came on and it was running really rough, almost like there was water in the gas. I shut it down, checked the fluids, everything was ok. Started it back up and it ran great again for another 10 min. and the same thing happened again! Every time the Check Engine came on, I was slowing down for a no wake zone. Didn't know if this was a coincidence or what. Any info would be great. Oh ya, and I hit 72.1mph twice with a 3/4 full gas tank. Water was about 49 degrees! F**king cold!


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,983
    +1
    1,900
    hit set 5 times and see if it gives you any trouble codes.

  3. #3
    Denali44's Avatar
    Join Date
    Jul 2005
    Location
    Maine
    Posts
    125
    ok, be right back in 2.

  4. #4
    Denali44's Avatar
    Join Date
    Jul 2005
    Location
    Maine
    Posts
    125
    all it said was end, let me guess, bad gas

  5. #5
    Denali44's Avatar
    Join Date
    Jul 2005
    Location
    Maine
    Posts
    125
    well I gotta run, time for some Gin and Tonics, but let me know if there is anything else I can do. I would love to be able to ride tomorrow!

  6. #6

    Join Date
    Jun 2005
    Location
    near detroit michigan
    Posts
    299
    next tiem the chk eng comes on then hit the button 5 times before u shut it off the code will appear. probly going to 1202 code its a oil press switch
    happened to me 2 times now wating for a new switch as we speak.

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,983
    +1
    1,900
    oil pressure switch failures are pretty common on these skis.

  8. #8
    Denali44's Avatar
    Join Date
    Jul 2005
    Location
    Maine
    Posts
    125
    will it hurt to ride it?

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,983
    +1
    1,900
    you really need to ride it. ride it and wait for the check engine light and at that time press set 5 times and then record the trouble code.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 rxp shut down CHECK ENG LIGHT ON help please!
    By scartigue in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-31-2011, 05:14 AM
  2. check engine light and error code P0351
    By cawky in forum 4-Tec Performance
    Replies: 16
    Last Post: 03-27-2009, 09:21 PM
  3. Check engine light and msg but no codE?
    By camar0 in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-15-2008, 03:22 AM
  4. Checked the pipes and...
    By 00pro785 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-28-2008, 10:40 PM
  5. check engine light came on when i went down to sea level
    By macattack in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-01-2005, 02:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •