Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Jul 2005
    Location
    Powhatan, VA
    Posts
    281

    Need some help ?

    I bought a new 04 RXP last spring and had the knock sensor upate done becaue rpm's were only 7400 prior to update.

    Stock RXP - Best was 69.9 mph & 7950 RPM

    Mods added at 19 hours on ski.
    Riva Intake Grate
    Solas 14/19R Prop
    New stock wear ring
    Riva Pro Sponsons
    RR Intercooler
    PPG Power Pipe

    Went out today and best MPH is 68.1 & 7950 rpm.

    Loaded ski on trailer and installed new Rotax Racing Race ECU by directions and removed piggy back update before installation.

    Went back on the water and my best mph are 69.1 at 8050 rpm.
    The holes shot is wild but why only 8050 rpm's and a speed less than my stock ski. Im ready for info?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,995
    +1
    1,901
    Rotax Racing "stock class" or "racing" ECU?

  3. #3

    Join Date
    Jul 2005
    Location
    Powhatan, VA
    Posts
    281
    Racing. I purchased through your store from Mark.

  4. #4
    buddydoo's Avatar
    Join Date
    Oct 2005
    Location
    houma
    Posts
    929
    +1
    5
    My wife's rxp(04) is doing the some thing with the rpm's at 7450 at top end.Is there a code that would show a problem with the knock sensor.

  5. #5

    Join Date
    Jun 2005
    Location
    near detroit michigan
    Posts
    299
    boost leak. and or the prop is too steep but shouldnt be
    try removing your ic block off and reinstalling it with some rtv or anarobic sealer on the gasket.

  6. #6

    Join Date
    Jul 2005
    Location
    Powhatan, VA
    Posts
    281
    I did use RTV on the Block Off when I installed it.

  7. #7

    Join Date
    Jul 2005
    Location
    Powhatan, VA
    Posts
    281
    Quote Originally Posted by buddydoo
    My wife's rxp(04) is doing the some thing with the rpm's at 7450 at top end.Is there a code that would show a problem with the knock sensor.
    Have youur dealer run your serial number and it will show if sensor update was ever done.

  8. #8
    buddydoo's Avatar
    Join Date
    Oct 2005
    Location
    houma
    Posts
    929
    +1
    5
    Cool,I know my 04 rxp was done,but I'm not sure if they did the other one that running bad.Thanks

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,995
    +1
    1,901
    Jason, now thats a thought!

    If they did the knock sensor update and installed the piggy back harness, but did not update the ECU as well it could be causing your low RPM problem.

  10. #10

    Join Date
    Jul 2005
    Location
    Powhatan, VA
    Posts
    281

    Re: Need some help ?

    Quote Originally Posted by RXP04
    I bought a new 04 RXP last spring and had the knock sensor upate done becaue rpm's were only 7400 prior to update.

    Stock RXP - Best was 69.9 mph & 7950 RPM

    Mods added at 19 hours on ski.
    Riva Intake Grate
    Solas 14/19R Prop
    New stock wear ring
    Riva Pro Sponsons
    RR Intercooler
    PPG Power Pipe

    Went out today and best MPH is 68.1 & 7950 rpm.

    Loaded ski on trailer and installed new Rotax Racing Race ECU by directions and removed piggy back update before installation.

    Went back on the water and my best mph are 69.1 at 8050 rpm.
    The holes shot is wild but why only 8050 rpm's and a speed less than my stock ski. Im ready for info?
    It was the block off leaking. Did it over with more RTV.
    Went out for a run this evening and results were a consistent
    74.4 mph at 8250 rpm. With the RR Race ECU limit at 8600 rpm, I should get close to 76 with another 150 rpm's to stay in the safe zone at 8400 rpm's. It is either going to be more air or prop pitching to get it. My air intake has only been modifed from the stock plastic box back to the stock rubber elbow that connects to the supercharger. I have a larger hose in this section. I removed my front bucket today and that allowed some air in since it not a tight seal. Jerry you got any extra discounts on that free flow hood ?
    I can tell you it did not take long to suck down 1/2 tank of gas at wide open speeds. But it rocks!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need some help guys, Lost 500rpm
    By CRS in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-15-2006, 05:24 PM
  2. need some help
    By Pettee in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-12-2006, 05:44 PM
  3. Need Some Help
    By Alex_GPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 03-19-2006, 09:36 PM
  4. Need some help planning a trip.
    By Pistonwash in forum Yamaha Open Discussion
    Replies: 21
    Last Post: 03-15-2006, 06:58 PM
  5. SeaDoo 3D (need some help)
    By MARKUS in forum 2-Stroke Performance
    Replies: 21
    Last Post: 02-09-2006, 05:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •