Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Sep 2006
    Location
    Los Angeles
    Posts
    28

    Engine Sputtering and Shaking

    I have a 2006 RXT, which for the last 2 rides seems to be running fine in the water (ocean). However, after taking it out of the water and after flushing the engine, when I press the throttle past 5,000 rpm, the engine sputters and the entire ski shakes. When the front part of the ski is raised (to remove excess water inside the hull), the sputtering and shaking actually get worse when I press the throttle past 5,000 rpm. I changed the spark plugs but it has no effect.

    Any suggestions would be appreciated.


  2. #2
    rior1's Avatar
    Join Date
    Feb 2007
    Location
    uk ESSEX
    Posts
    356
    have you done any work lately?,have u checked all your hoses,slip in the sc
    i had clogged injectors the engine shook but not the whole ski

  3. #3

    Join Date
    Sep 2006
    Location
    Los Angeles
    Posts
    28
    I haven't done any work to the ski. I guess I will have to check all the hoses.

  4. #4
    ISLAND RACING seadoo951's Avatar
    Join Date
    Jan 2007
    Location
    Longisland, NY
    Posts
    843
    Might be a pump issue

  5. #5
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    Does it run ok though? You can also check the pump area and see if there's something in there...

  6. #6

    Join Date
    Sep 2006
    Location
    Los Angeles
    Posts
    28
    It seems to run fine because I don't notice any difference in the water, even when doing WOT. It's only when the ski is out of the water and I rev the engine at over 5,000 rpm that the sputtering and shaking happen.

    I'll check the hoses and the pump, but I am not mechanically inclined and the thought of taking it to a dealership (based on some of the horror stories) has me a little concerned.

  7. #7
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    How many rpms does it turn on the water?

  8. #8

    Join Date
    Sep 2006
    Location
    Los Angeles
    Posts
    28
    It turns 7,780 rpm, which is what is was turning since I installed a 14/19 impeller about 3 months ago (Prior to 14/19, it was turning 7,950 rpm on the original impeller). As I previously mentioned, on the water it seems normal - I don't notice any problems. It's only when I take it out of the water and rev the throttle past 5,000 rpm that my ski sputters and shakes. Sputtering and shaking become worse if I rev past 5,000 rpm with the front of the ski raised. I tried it again today and same thing. I can't figure it out .

  9. #9
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    That's weird bro....COME ON someone help this guy out...

  10. #10
    Been there and back! BDNJ's Avatar
    Join Date
    Jul 2005
    Location
    Silver Bay, Toms River, N.J.
    Posts
    1,536
    1st - Inspect the driveshaft to make sure you don't have a rope or something on the driveshaft.
    2nd - (and I think this is it) remove the pump and make sure the prop is properly tightened down on the splines of the pump. If the prop is loose it will "walk" forward down the shaft, chew up your pump shoe area, leak water, vibrate loudly and scrub speed!!!!!

    P.S. -you cannot inspect it from looking from the outside. You need to remove it to tell.

    Just my .02
    Brendan

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine removal and installation links
    By Smitty in forum Yamaha How To & FAQs
    Replies: 3
    Last Post: 01-04-2013, 08:28 PM
  2. engine management and control
    By spaulding in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 10-03-2007, 06:38 AM
  3. Engine surges and RPM difference
    By mrcfjf in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 06-13-2007, 06:21 PM
  4. New reverse engine installed, and pics of new test tank.
    By Rodneyae in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-22-2007, 05:31 PM
  5. Engine Boggs and dies near 4000
    By gvnitup in forum Polaris Open Discussion
    Replies: 9
    Last Post: 05-13-2007, 04:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •