Results 1 to 3 of 3
  1. #1
    1996 SL900 & SL700 turk0004's Avatar
    Join Date
    Jul 2007
    Chicago IL

    When did they start putting odometers on the older SLT's?

  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.

  3. #3
    polarispa's Avatar
    Join Date
    Aug 2006
    Cranberry PA
    According to the "dash" its got turn signals too.
    Hmm according to the mileometer it has done 114178 miles and he said it has been running for 110 hours thats an average speed of 1038 MPH !!!
    I only get about 50 outta my 750
    Some people must think that the average buyer out there is stupid that most would not figure out what is wrong with his ad.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is it safe to start the waverunners before you put them in the water?
    By crvtt771 in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 05-07-2012, 09:01 PM
  2. When did the GPR's start to run setback pumps??
    By Mongoose in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 04-08-2011, 07:13 AM
  3. Did they think when building this?
    By L Carlson in forum Open Discussion
    Replies: 12
    Last Post: 11-27-2009, 10:23 AM
  4. What year did they start producing "quality" 4 stroke skis???
    By Alberta Boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-14-2007, 03:37 PM
  5. When did all of the Exhaust kits go out?
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-17-2006, 01:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts