Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Feb 2007
    Location
    Redlands, CA
    Posts
    5

    2001 virage tx MFD BLANK

    I put my battery back into my ski, and MFD is just blank. I looked in service manual and they talk about a possible blown fuse. But where is the fuse. The ski started fine but no display on mfd screen.
    I tried undoing neg battery cable wait 1 minute and reattached, unplugged mfd and plugged back in but no change. Any suggestions????

    Thanks much
    Jerry


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    The fuse is inside the electrical box it should be 1/4amp

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Quote Originally Posted by beerdart View Post
    The fuse is inside the electrical box it should be 1/4amp
    Be sure not to replace it with anything larger than 1/4 amp IF that is whats in it now.
    Always disconnect the MFD's when charging or changing the battery as the voltage spike will take out the MFD's if the fuse doesn't protect it.

  4. #4

    Join Date
    Feb 2007
    Location
    Redlands, CA
    Posts
    5
    Thanks for the info. I am kind of a green horn at this. Does the electrical box just pop open or is there a trick to getting open.


    Thanks
    Jerry

  5. #5
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Quote Originally Posted by remmahj View Post
    Does the electrical box just pop open or is there a trick to getting open.
    There are 4 catches (2 on each side) that hold the box together.

  6. #6

    Join Date
    Feb 2007
    Location
    Redlands, CA
    Posts
    5
    I opened the electrical box and the the fuse was ok, and tried the reset button. Is there any way to ck to see if mfd is any good. I would hate to buy a new one and have it not work also.

    thanks again

    Jerry

  7. #7

    Join Date
    Apr 2007
    Location
    NC
    Posts
    67
    Quote Originally Posted by remmahj View Post
    I opened the electrical box and the the fuse was ok, and tried the reset button. Is there any way to ck to see if mfd is any good. I would hate to buy a new one and have it not work also.

    thanks again

    Jerry
    Just a thought, because I went through the same thing.

    Make sure to check the fuse with meter or continuity tester, or just try another one. Mine looked OK, but the element was bad near the end cap where you could not see it. There should be a spare fuse n the electrical box.

    Tom

  8. #8
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Quote Originally Posted by remmahj View Post
    I opened the electrical box and the the fuse was ok, and tried the reset button. Is there any way to ck to see if mfd is any good. I would hate to buy a new one and have it not work also.

    thanks again

    Jerry
    i got an extra harness and mfd (reads wrong volts and rpm ) but i will help you test
    send me pm
    mattman

  9. #9
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Verify you have 12 volts at the red/purple to the MFD
    Verify you have ground at the MFD

  10. #10
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    I had the same problem on my Virage after hitting a big wave. Turned out to be a loose connector in the electric box. You might check all of them and make sure they are tight.

    Just a thought.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Virage TX 1200 Ficht
    By wetwelder in forum Polaris How To & FAQs
    Replies: 22
    Last Post: 10-05-2016, 05:09 PM
  2. 2001 virage tx mfd ???
    By bossdog67 in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 08-11-2009, 10:39 PM
  3. 2001 virage tx exaust
    By jbloc in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 09-10-2007, 06:24 PM
  4. 2001 Virage TX Stator Settings
    By jamp in forum Polaris PWC Performance
    Replies: 2
    Last Post: 07-11-2007, 03:05 PM
  5. Need help with a 2001 Virage Tx
    By grammylinny in forum Polaris Open Discussion
    Replies: 27
    Last Post: 07-01-2007, 08:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •