Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    xcduetester's Avatar
    Join Date
    Sep 2005
    Location
    Sunny Florida
    Posts
    85

    Boo Hoo, so disappointed......

    Well, as some of you may remember, I sold my twin GTX's last year as I could not depend on them. As a girl who quite often ski's alone I must have a boat I can rely on. So, girl buys new GTX, yea! so happy!! Well, 3 hrs. into breakin the lanyard deceides not to work, so get back to shore with learning key. Next day out, yellow works white does not!?? Wanting to hurry up and get those 10 breakin hours on so can open her up so went out again today for an Easter ride. Hour 5 on ski, trucking along and bingo, out of no where I start having MAJOR power/no power surges, almost stalls out, idles ok. Girl thinks try learning key maybe faulty lanyard connection, learning key useless. So I ride it like a bronco all the way to the ramp (about 40 mins) in gator infested water.
    Will check fuel filter tomarrow (if I can find it) and if no issues will haul it to the shop. So much for a new trouble free boat. Was wondering if anyone else on this board has had related issue's? Oh, the oil was over-filled from the start if that could possibly mean anything???
    All this and I bruised the heck out of my knee and lost my favorite flip flop. Oh, what a day : (


  2. #2
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,360
    +1
    339
    It pains me to say it, but if you were looking for trouble free dependability; Sea-doo might not have been the best choice.

    Sorry you had problems- hope you get them worked out.

    I think all the new 4-tecs only have a fuel filter inside the tank contained within the pump module- don't think they have an external filter.

  3. #3
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,360
    +1
    339
    I don't know if oil over-filling could cause those type of problems. I guess it would depend on how much it was over-filled. A good place to start would be taking out that extra oil though...

  4. #4
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    call Umstadt and tell him to come fix your ski. It sounds like an electrical/electronic problem to me and a trip back to the dealer is what it will take to fix it.

  5. #5
    xcduetester's Avatar
    Join Date
    Sep 2005
    Location
    Sunny Florida
    Posts
    85
    Thanks for your input guys, someone will be hearing from me for sure. I've been waiting a long time for this baby and certainly didn't expect immediate or any problems for that matter.
    Sure they will make good...... just hope good and FAST.

  6. #6
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Where in florida are u?

  7. #7
    Kaybat's Avatar
    Join Date
    Aug 2005
    Location
    Ormond Beach,fl
    Posts
    1,715
    +1
    28
    If the ski is new, bring it back to dealer and say FIX IT!!

  8. #8
    Site Admin MikeTrin's Avatar
    Join Date
    Apr 2005
    Location
    Overland Park, ks
    Posts
    4,186
    +1
    48
    FYI: I just removed 8 or so inappropriate replies to this thread. Let's try to stay on topic guys.

    Thanks,
    Your friendly Asian wana-bee.

  9. #9
    way2fast's Avatar
    Join Date
    May 2005
    Location
    Melbourne Beach, FL
    Posts
    4,013
    +1
    3
    Thanks Mike.....I was just going to give one of the "posters" a piece of my mind. Someone asks for some advice and she gets bombarded by a bunch of nitwits. I haven't been on here for a long time and from what I heard earlier today I thought this "informative forum" had turned into a kidde circus as did so many of the other PWC forums. I'm encouraged to see that the BS is not acceptable here.


    Richard

  10. #10
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,698
    +1
    21
    Sorry Richard and exseadootester. My humor and Bud Light was in poor judgement. Peace!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. woo hoo I got Boost
    By meirvin in forum 4-Tec Performance
    Replies: 5
    Last Post: 02-10-2007, 07:53 PM
  2. WHO HOO!!! today i ran 74.2 MPH with my moded RXT in 90 deg air
    By GPR/STX-15F/RXT in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-24-2006, 08:18 AM
  3. Anyone else disappointed in their Jettrim cover?
    By GPR FL in forum Videos & Pictures
    Replies: 20
    Last Post: 05-24-2006, 11:46 AM
  4. Whoo Hoo get to change my Sig
    By meirvin in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-13-2006, 04:01 AM
  5. Woo Hoo!!! real racing starts this weekend!!
    By two2curupt in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 03-09-2006, 09:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •