Results 1 to 10 of 10
  1. #1

    Join Date
    Oct 2007
    Location
    PA, USA
    Posts
    4

    07 GTX Ltd Bent Rod

    We have two new ski's and the GTX has a major problem if anyone has any info. that can help it would be greatly appricated. At 19 hrs the dealer did a service(oil change and check over). Within 2 hours of service pulling a tube the oil light came on. I check the level and it was 2 1/2 qts. low, filled with the proper oil it was smoking like crazy. I check the air inlet duct and it was dry and clean. No oil or water residue. I removed the supercharger outlet duct to the throttle valve and found oil coating everything. I figure its a bad supercharger oil seal and tried to run the excess out of the engine without the duct attached. Way to much smoke, after 30min. I had to stop. I removed the intercooler from the intake manifold and it was still wet with oil. I figure the kids didn't do anything wrong so off the the dealer for warranty repairs. They found a bent rod in the rear cylinder, no water in the oil at all but state it is from being swamped because the seat is heavy from water. They found no problem with the supercharger.. Of course they do not want to cover it under warrenty. My thought is that if the intake filled with oil from the SC it could cause a hydraulic effect(same as water) in the cylinder that got a gulp of oil when turned at the right angle. Has anyone had this problem? The kid say they didnt swamp it, I trust them and the oil had to go somewhere.

    Thanks for any help


  2. #2
    ....I'll defer...
    Last edited by VaRedneck; 10-23-2007 at 10:14 PM.

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    What method did you check the oil?

    Did it start smoking after you added 2 1/2 quarts?
    If you over filled the oil by 2 1/2 quarts then its possible you caused the hydrolock.
    Last edited by Green Hulk; 10-23-2007 at 09:45 PM.

  4. #4

    Join Date
    Oct 2007
    Location
    PA, USA
    Posts
    4

    rod bent

    It was towed it back to my house on the trailer. checked the oil with the dip stick. slowly filling it till we were able to get a reading. left it about 1/2 qt. shy of full on level surface before running it. It started and ran like normal, no abnormal noises heard from engine, and the oil light was now off. smoke like hell though. rechecked the oil level many times with it reading the same. Is it possible with the tilt of the engine/ski pulling the tube around that the oil in the crankcase collecting to the rear of the engine could be drawn into to supercharger. Only a guess because I don't know how the internal drive is set up for the supercharger. One thing is the intake is an up draft type which would let oil or water to pool at the lowest point. Note these two ski's belong to my xwife and our kids were the ones using them at the time so I was not there when it happen. I have two XP's myself. Thanks again.

  5. #5
    HORSEPOWER JUNKIE 9secZO6's Avatar
    Join Date
    Jun 2007
    Location
    Belle Chasse, La.
    Posts
    2,006
    +1
    1
    For discussion purposes, know that the engine could have been hydro-locked previously, and would still run. In that case (with bent rod) the piston/rings will wear the cyl. egg-shaped, and it will smoke like mosquito-control truck. This will happen in just a few mins. to a couple hours, depending on how bent the rod is. If the seat was heavy w/ water, it would indicate to me possible submarine manuevers. I use the word possible, as that is all they need to say to try to make u pay. This sucks but then, u don't need me to tell u that. For what it is worth, 1 of mine had a bent rod, continued to run it (was in denial) and the block is now ventilated and fits loosely in a 5-gallon bucket At least it sounds as if yours is re-buildable.

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    To properly check the engine oil you must first have a hot engine.

    Let it idle for 30 seconds

    Shut it off

    Wait 30 seconds

    Check the oil

    It should be mid way between the two bends on the stick.

    Failing to use this method would result in an improper reading (a low one) causing you to think you needed more oil.

    Adding 2 1/2 more quarts to an engine with a proper oil level will cause all sorts of issues.... including excessive smoking after adding the oil
    Last edited by Green Hulk; 10-24-2007 at 04:29 PM.

  7. #7
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    You really need to talk to another dealer that can form their own opinions from your details. It might take driving your ski to south Florida, but it will be worth it... Ron

  8. #8

    Join Date
    Oct 2007
    Location
    PA, USA
    Posts
    4

    07GTX twisted and smokin

    Thank's for the insight. As I mention the oil light was on, with nothing reading on the stick. I know there is not a lot of info. for you to go on other then what is posted. I do appricate the help. In my twenty some year in the outomotive field I have seen oil pressure fead superchargers and turbos loose their seals/bearings and really blow some oil. The differance is you normally keep the dirty side down in a car, unlike a ski.
    Are the washers everyone talks of the only type of seal or are they a poor shim for the SC shaft? The dealer, Motosports in PA said there is a new Titanium set out now for the 08's just made available.
    First they were not going to cover it. Then I called SeaDoo's customer service, they called me back the next day and stated they would cover it. They said they would let the dealer know. Great ...I waited as to not bug them for a couple weeks. Called Motosports and they had heard nothing about it and they would call SeaDoo and straighten it out. I heard nothing so I figured they were working on it.Called a couple weeks later and they said Oh SeaDoo technical was going to call you they didn't know about it either. I called customer service again and tried to explain to this lady that had no clue what I was talking about LOL. All she could say is customer service could not authorize repairs and somebody would call me. Maybe by the time the 09's are out it might be ready I'll let you know how it ends up.

    Thanks again Pat

  9. #9

    Join Date
    Oct 2007
    Location
    PA, USA
    Posts
    4

    Bent Rod

    Sea Doo covered 100% of repairs and is putting her back together now. They also install 08 SC metal washers.

  10. #10
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    thats good, what finally was the problem?? what repairs are they doing??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help...Questions regarding 07 GTX LTD Supercharged
    By samudj01 in forum 4-Tec Performance
    Replies: 3
    Last Post: 11-14-2013, 07:02 AM
  2. Slop in tilt steering on '07 GTX Ltd
    By ndgtxltd in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 10-15-2009, 11:24 AM
  3. gtx 155 vs 07 gtx ltd vs 03 gtx ltd vs gp1300r stg 2
    By lee cutting in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-31-2009, 06:16 PM
  4. 07 gtx ltd 215, light mod questions
    By goose5741 in forum 4-Tec Performance
    Replies: 6
    Last Post: 01-24-2008, 07:26 PM
  5. 07 gtx ltd question
    By JOJO567 in forum 4-Tec Performance
    Replies: 12
    Last Post: 11-10-2007, 11:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •