Results 1 to 10 of 10
  1. #1

    Unhappy 96 XP Battery Draining

    I have a 96 XP. When I plug in the cable that goes to the Magneto coil, I can watch the voltage on the battery drop. When I disconnect it, the battery voltage will rise. Anyone seen this? Is it the coil or something else?


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by shooter700_007 View Post
    I have a 96 XP. When I plug in the cable that goes to the Magneto coil, I can watch the voltage on the battery drop. When I disconnect it, the battery voltage will rise. Anyone seen this? Is it the coil or something else?
    Welcome!

    What cable are you referring to? Can you do a search? We've hammered this subject many times...you aren't the first...

  3. #3

    Unhappy

    It is the cable that runs from the Electrical System Box to the Stator Plate. Tried searching but not sure what exactly to search for.

  4. #4
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Try replacing the rectifier in the gray box first. It is not blowing any fuses, right?

    If the engine has never been submerged underwater, then the stator is probably ok. Make sure the pins in the front cover plug receptacle, and plug, are not corroded if it is a saltwater ski.

    Make sure all your grounds are good too.

  5. #5
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    In case you aren't sure what it is, the rectifier has three thick yellow wires coming from it and one thick red.

  6. #6
    Thanks for the reply. It is not blowing any fuses. I don't think it has been submerged, but I just bought it, and it had the existing problem. Will check on the connectors and double check the grounds. Where on line is a good place to buy SeaDoo parts?

  7. #7

    Join Date
    Dec 2006
    Location
    Cartersville, GA
    Posts
    59
    Check for a grounded stator. I bet you will find it!!

  8. #8
    I am having that problem as well. I was out on the water last summer, 17 minutes later my battery light came on. It was great all year until it's last ride. I have the service manual in PDF format, did the diagnostic on the MPEM, DC-CDI and stator. Turns out my DC-CDI has failed some resistance values in the book. I think what is going on, is that the DC-CDI module is keeping something energized at all times. If you disconnect the black lead off your battery and just touch it to the battery...you should see it jump a fat spark. I tested all wires leading up to the regulator/rectifier and found when I disconnect the red lead which runs into the MPEM the black lead on the battery would stop arcing. I assume that red lead going into the MPEM is related to the DC-CDI as they do hook up at some point in the grey box. Waiting on replacement parts to see if it cures the problem. 96XPSS has a lot of great info...def. worth taking to heart. Thanks for the help fella.
    Last edited by Schwarzenegger; 03-09-2008 at 01:49 AM.

  9. #9

    battery draining

    I suggest you give John at Jet Ski Solutions a call and send the CDI to him he will fix you right up at half the cost of a new one. www.jetskisolutions.com he does all my electrical work from cdi to complete wiring!!!

  10. #10
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    There is nothing to fix in a Seadoo cdi.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 XP drains battery in 2 minutes
    By customcruiser in forum 2-Stroke Performance
    Replies: 39
    Last Post: 09-01-2013, 10:40 PM
  2. 96 Seadoo Xp 800 Need help with Battery Drain ASAP
    By mikeashley24 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-08-2011, 04:49 PM
  3. 96 XP Battery
    By Big Boi in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-15-2011, 01:24 PM
  4. 94 650 xp battery drains...
    By dariverrat in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-15-2008, 03:49 PM
  5. 96 XP Engine Not Charging Battery
    By 1996SLTX in forum 2-Stroke Performance
    Replies: 9
    Last Post: 03-07-2008, 07:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •